Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-63762

Pipeline script editor requires deprecated jquery-ui plugin for expand/shrink behaviour

    XMLWordPrintable

    Details

    • Similar Issues:

      Description

      Jquery-UI: 1.0.2
      Pipeline-Job: 2.39

      The Pipeline script editor (and likely other editors) requires the deprecated jquery-ui plugin for expand/shrink/resize behaviour.  It would be useful to implement an alternative capability to resize editors.

        Attachments

          Issue Links

            Activity

            Show
            pwiseman Peter Wiseman added a comment - Christian Höltje 's solution in JENKINS-38276 does not required the jquery-ui plugin. https://issues.jenkins-ci.org/browse/JENKINS-38276?focusedCommentId=385456&page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#comment-385456
            Hide
            fqueiruga Félix Queiruga Balado added a comment -

            I have created a PR that upgrades jQuery and jQueryUi to latest and secure versions. It is https://github.com/jenkinsci/workflow-cps-plugin/pull/391 . 

            Show
            fqueiruga Félix Queiruga Balado added a comment - I have created a PR that upgrades jQuery and jQueryUi to latest and secure versions. It is https://github.com/jenkinsci/workflow-cps-plugin/pull/391  . 

              People

              Assignee:
              fqueiruga Félix Queiruga Balado
              Reporter:
              pwiseman Peter Wiseman
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

                Dates

                Created:
                Updated: