Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-63933

Jobs got stuck during execution on agents

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: core
    • Labels:
    • Environment:
      Jenkins 2.261
    • Similar Issues:
    • Released As:
      Jenkins 2.262

      Description

      With the newest update of jenkins 2.261, my builds started to never finish  .

      Pipelines builds or classical builds all stay stucked indefinitely on the warning analysis step.

       

      Classical build(when arriving to the post build steps):

      // code placeholder
      05:45:54 [Cobertura] Setting Build to unstable.
      05:45:54 [Cobertura] Setting Build to unstable.
      05:45:54 
      08:13:44 ERROR: Build step failed with exception
      08:13:44 java.lang.InterruptedException
      08:13:44  at java.lang.Object.wait(Native Method)
      08:13:44  at hudson.remoting.Request.call(Request.java:176)
      08:13:44  at hudson.remoting.Channel.call(Channel.java:1000)
      08:13:44  at hudson.FilePath.act(FilePath.java:1070)
      08:13:44  at hudson.FilePath.act(FilePath.java:1059)
      08:13:44  at io.jenkins.plugins.analysis.core.model.ReportScanningTool.scanInWorkspace(ReportScanningTool.java:149)
      08:13:44 Caused: edu.hm.hafner.analysis.ParsingCanceledException: Canceling parsing since build has been aborted.
      08:13:44  at io.jenkins.plugins.analysis.core.model.ReportScanningTool.scanInWorkspace(ReportScanningTool.java:159)
      08:13:44  at io.jenkins.plugins.analysis.core.model.ReportScanningTool.scan(ReportScanningTool.java:131)
      08:13:44  at io.jenkins.plugins.analysis.core.steps.IssuesScanner.scan(IssuesScanner.java:101)
      08:13:44  at io.jenkins.plugins.analysis.core.steps.IssuesRecorder.scanWithTool(IssuesRecorder.java:681)
      08:13:44  at io.jenkins.plugins.analysis.core.steps.IssuesRecorder.record(IssuesRecorder.java:646)
      08:13:44  at io.jenkins.plugins.analysis.core.steps.IssuesRecorder.perform(IssuesRecorder.java:617)
      08:13:44  at io.jenkins.plugins.analysis.core.steps.IssuesRecorder.perform(IssuesRecorder.java:595)
      08:13:44  at hudson.tasks.BuildStepMonitor$1.perform(BuildStepMonitor.java:20)
      08:13:44  at hudson.model.AbstractBuild$AbstractBuildExecution.perform(AbstractBuild.java:804)
      08:13:44  at hudson.model.AbstractBuild$AbstractBuildExecution.performAllBuildSteps(AbstractBuild.java:753)
      08:13:44  at hudson.model.Build$BuildExecution.post2(Build.java:177)
      08:13:44  at hudson.model.AbstractBuild$AbstractBuildExecution.post(AbstractBuild.java:698)
      08:13:44  at hudson.model.Run.execute(Run.java:1932)
      08:13:44  at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:43)
      08:13:44  at hudson.model.ResourceController.execute(ResourceController.java:97)
      08:13:44  at hudson.model.Executor.run(Executor.java:428)
      08:13:44 Build step 'Record compiler warnings and static analysis results' marked build as failure
      

       

      And a pipeline build:

      [Pipeline] recordIssuesAborted by 
       C.dric
      [Pipeline] }[Pipeline] // stage[Pipeline] }[Pipeline] // node[Pipeline] }[Pipeline] // timestamps[Pipeline] End of Pipeline[Checks API] No suitable checks publisher found.
       java.lang.InterruptedException
       at java.lang.Object.wait(Native Method)
       at hudson.remoting.Request.call(Request.java:176)
       at hudson.remoting.Channel.call(Channel.java:1000)
       at hudson.FilePath.act(FilePath.java:1070)
       at hudson.FilePath.act(FilePath.java:1059)
       at io.jenkins.plugins.analysis.core.model.ReportScanningTool.scanInWorkspace(ReportScanningTool.java:149)
       Caused: edu.hm.hafner.analysis.ParsingCanceledException: Canceling parsing since build has been aborted.
       at io.jenkins.plugins.analysis.core.model.ReportScanningTool.scanInWorkspace(ReportScanningTool.java:159)
       at io.jenkins.plugins.analysis.core.model.ReportScanningTool.scan(ReportScanningTool.java:131)
       at io.jenkins.plugins.analysis.core.steps.IssuesScanner.scan(IssuesScanner.java:101)
       at io.jenkins.plugins.analysis.core.steps.IssuesRecorder.scanWithTool(IssuesRecorder.java:681)
       at io.jenkins.plugins.analysis.core.steps.IssuesRecorder.record(IssuesRecorder.java:646)
       at io.jenkins.plugins.analysis.core.steps.IssuesRecorder.perform(IssuesRecorder.java:617)
       at io.jenkins.plugins.analysis.core.steps.RecordIssuesStep$Execution.run(RecordIssuesStep.java:1024)
       at io.jenkins.plugins.analysis.core.steps.RecordIssuesStep$Execution.run(RecordIssuesStep.java:985)
       at org.jenkinsci.plugins.workflow.steps.SynchronousNonBlockingStepExecution.lambda$start$0(SynchronousNonBlockingStepExecution.java:47)
       at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)
       at java.util.concurrent.FutureTask.run(FutureTask.java:266)
       at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149)
       at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624)
       at java.lang.Thread.run(Thread.java:748)
       Finished: ABORTED
      

      I had to abot those builds manually after a few hours for the first and about 30 minutes for the second. Of course, those parts were done previously very fast.

       

      Downgrading to jenkins 2.260 fixes the problem.

        Attachments

          Issue Links

            Activity

            joseph_witthuhn Joseph Witthuhn added a comment -

            We are seeing this issue on Java 8.

            oleg_nenashev Oleg Nenashev added a comment -

            I confirm the regression is caused by JENKINS-63937, https://github.com/jenkinsci/jenkins/pull/4999 resolves this issue as well. I will continue analysis, but for  now I suggest reverting the patch and doing out of order release

            oleg_nenashev Oleg Nenashev added a comment -

            New weekly release is in progress. It will take a few hous until the release is done

            joseph_witthuhn Joseph Witthuhn added a comment - - edited

            Do we believe that this is fixed in 2.262, which includes that pull request? If so, will we have to upgrade our agent JAR files as well to implement this fix?

            oleg_nenashev Oleg Nenashev added a comment -

            Yes, it should be fixed. No agent upgrade required


              People

              Assignee:
              oleg_nenashev Oleg Nenashev
              Reporter:
              cdric cdric julien
              Votes:
              5 Vote for this issue
              Watchers:
              10 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: