Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-64028

error while loading shared libraries

    XMLWordPrintable

    Details

    • Similar Issues:

      Description

      I have issue when create build in shared library as the following log :

      what should i do ?

      i try to install libpulse.so.0 via "apt-get install 'libpulse0'" not resolved .

       
      in workspace /var/jenkins/workspace/Android-Emulator
      $ /var/jenkins/tools/android-sdk/tools/bin/avdmanager list target
      $ /var/jenkins/tools/android-sdk/tools/bin/sdkmanager --sdk_root=/var/jenkins/tools/android-sdk --list --verbose
      [android] Using Android SDK: /var/jenkins/tools/android-sdk
      [android] Creating Android AVD: /var/jenkins/workspace/Android-Emulator/.android/avd/hudson_en-US_160_HVGA_android-27_x86.avd
      [android] /var/jenkins/tools/android-sdk/tools/bin/avdmanager create avd -f -c 64M -n hudson_en-US_160_HVGA_android-27_x86 -k system-images;android-27;default;x86
      Loading local repository...
      [========= ] 25% Loading local repository...
      [========= ] 25% Fetch remote repository...
      [=======================================] 100% Fetch remote repository...
      Auto-selecting single ABI x86
      Do you wish to create a custom hardware profile? [no]
      $ /var/jenkins/tools/android-sdk/platform-tools/adb start-server

      • daemon not running; starting now at tcp:5842
      • daemon started successfully
        $ /var/jenkins/tools/android-sdk/platform-tools/adb start-server
        [android] Starting Android emulator
        $ /var/jenkins/tools/android-sdk/emulator/emulator -skin 320x480 -ports 5702,5703 -report-console tcp:5810,max=60 -prop persist.sys.language=en -prop persist.sys.country=US -avd hudson_en-US_160_HVGA_android-27_x86
        /var/jenkins/tools/android-sdk/emulator/qemu/linux-x86_64/qemu-system-x86_64: error while loading shared libraries: libpulse.so.0: cannot open shared object file: No such file or directory
        [android] Emulator did not appear to start; giving up
        [android] Stopping Android emulator
        $ /var/jenkins/tools/android-sdk/platform-tools/adb kill-server
        Finished: NOT_BUILT

       

        Attachments

          Activity

          Hide
          nfalco Nikolas Falco added a comment -

          The emulator tries to load the audio of that machine.

          Or the build user does not have the privileges, or installed a 64bit library but the emulator i 32bit or you miss to install the pulseaudio system package.

          In any case you can set an env var QEMU_AUDIO_DRV=none to disable audio load. The android plugin can not hadle/install system package.

          Show
          nfalco Nikolas Falco added a comment - The emulator tries to load the audio of that machine. Or the build user does not have the privileges, or installed a 64bit library but the emulator i 32bit or you miss to install the pulseaudio system package. In any case you can set an env var QEMU_AUDIO_DRV=none to disable audio load. The android plugin can not hadle/install system package.
          Hide
          mohamedtae Muhammad Ali added a comment -

          i solved the issue by copy library "libpulse.so.0" from /lib/x86_64-linux-gnu to */usr/lib

          **thanks

          Show
          mohamedtae Muhammad Ali added a comment - i solved the issue by copy library "libpulse.so.0" from  /lib/x86_64-linux-gnu   to * /usr/lib *  ** thanks

            People

            Assignee:
            nfalco Nikolas Falco
            Reporter:
            mohamedtae Muhammad Ali
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: