Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-64100

Getting an Unknown error without any further information

    XMLWordPrintable

    Details

    • Similar Issues:

      Description

      Using Jenkins for running automation tests and the run fails with the following error message:
       

      hudson.util.jna.JnaException: Win32 error: 2 - null
      

      I don't really know what causes the error or from where the error comes, any explaination would be useful.

      A little further info:

      • Tests are run in interactive mode with username and password,
      • Newest Versions for Test Execute and Test Complete are used,
      • Jenkins isn't configured to start directly as a windows service but does that over the master.

      Question: There is a similiar issue with cygwin not being recognized but I don't see the connection in Cygwin-My issue.

        Attachments

          Activity

          Hide
          emcity Jan Zavec added a comment -

          Nikolas Falco, tagging some people from other Test Complete related issues, might speed up things (:.

          Show
          emcity Jan Zavec added a comment - Nikolas Falco , tagging some people from other Test Complete related issues, might speed up things (:.
          Hide
          nfalco Nikolas Falco added a comment -

          Xunit plugin does not use jna neither dll

          Show
          nfalco Nikolas Falco added a comment - Xunit plugin does not use jna neither dll
          Hide
          emcity Jan Zavec added a comment - - edited

          Any further explaination of what exactly you mean with that Nikolas Falco?

          I guess you meant that the plugin doesn't use jna so the error can't be connected to the actual plugin but has to be an underlying issue somewhere else.

          Show
          emcity Jan Zavec added a comment - - edited Any further explaination of what exactly you mean with that Nikolas Falco ? I guess you meant that the plugin doesn't use jna so the error can't be connected to the actual plugin but has to be an underlying issue somewhere else.
          Hide
          nfalco Nikolas Falco added a comment - - edited

          The issue is related to permissions of the user that run jenkins/file permission. I can not say more than this because of few informations in the issue, miss of application/lib logs.

           

          Show
          nfalco Nikolas Falco added a comment - - edited The issue is related to permissions of the user that run jenkins/file permission. I can not say more than this because of few informations in the issue, miss of application/lib logs.  
          Hide
          emcity Jan Zavec added a comment - - edited

          Thank you very much. I'll try to fix it else I'll add more information.

          Show
          emcity Jan Zavec added a comment - - edited Thank you very much. I'll try to fix it else I'll add more information.
          Hide
          emcity Jan Zavec added a comment -

          Hi Nikolas Falco, where can I find the application/lib logs, are this the logs from the Jenkins Machine which runs Test Complete/Execute, or the Jenkins master machine.

          Show
          emcity Jan Zavec added a comment - Hi Nikolas Falco , where can I find the application/lib logs, are this the logs from the Jenkins Machine which runs Test Complete/Execute, or the Jenkins master machine.

            People

            Assignee:
            mgaert Michael Gärtner
            Reporter:
            emcity Jan Zavec
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated: