Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-64226

Jenkins not starting with AdoptJDK 11.0.9.1+1

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Duplicate
    • Component/s: core
    • Labels:
      None
    • Similar Issues:
    • Released As:
      Jenkins core 2.263.1

      Description

      I'm using Jenkis wirh Java 11. It worked with

      • AdoptJDK 11.0.6+10
      • AdoptJDK 11.0.7+10
      • AdoptJDK 11.0.8+10

      Java 11 is my system JDK under Ubuntu 20.04.1. Now the JDK was updated to 11.0.9.1+1. And Jenkis was not starting. The Java Version check is in /etc/init.d/jenkins

       

      ● jenkins.service - LSB: Start Jenkins at boot time
       Loaded: loaded (/etc/init.d/jenkins; generated)
       Active: failed (Result: exit-code) since Sat 2020-11-14 20:25:59 CET; 12min ago
       Docs: man:systemd-sysv-generator(8)
       Process: 134595 ExecStart=/etc/init.d/jenkins start (code=exited, status=1/FAILURE)
      Nov 14 20:25:59 nuc-mini-server systemd[1]: Starting LSB: Start Jenkins at boot time...
      Nov 14 20:25:59 nuc-mini-server jenkins[134595]: Found an incorrect Java version
      Nov 14 20:25:59 nuc-mini-server jenkins[134595]: Java version found:
      Nov 14 20:25:59 nuc-mini-server jenkins[134626]: openjdk version "11.0.9.1" 2020-11-04
      Nov 14 20:25:59 nuc-mini-server jenkins[134626]: OpenJDK Runtime Environment AdoptOpenJDK (build 11.0.9.1+1)
      Nov 14 20:25:59 nuc-mini-server jenkins[134626]: OpenJDK 64-Bit Server VM AdoptOpenJDK (build 11.0.9.1+1, mixed mode)
      Nov 14 20:25:59 nuc-mini-server jenkins[134595]: Aborting
      Nov 14 20:25:59 nuc-mini-server systemd[1]: jenkins.service: Control process exited, code=exited, status=1/FAILURE
      Nov 14 20:25:59 nuc-mini-server systemd[1]: jenkins.service: Failed with result 'exit-code'.
      Nov 14 20:25:59 nuc-mini-server systemd[1]: Failed to start LSB: Start Jenkins at boot time.
      

       

      The new java Version has the internal Version 11.09. I added this version to the start script. And now it's working.

        Attachments

          Issue Links

            Activity

            markewaite Mark Waite added a comment -

            Duplicate of Jenkins-64212. Refer to it and https://github.com/jenkinsci/packaging/pull/198 for the technique you can apply immediately to resolve the issue.


              People

              Assignee:
              Unassigned Unassigned
              Reporter:
              oicfar Rafal Kedziorski
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: