Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-64313

Config File Plugin configuration UI completely broken and cannot save anymore after upgrade to 2.264

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Blocker
    • Resolution: Fixed
    • Environment:
    • Similar Issues:

      Description

      The Config File Plugin configuration UI is completely broken and I cannot save anymore after upgrade to 2.264.

      https://github.com/jenkinsci/config-file-provider-plugin/search?q=table

        Attachments

          Activity

          gaborv Gabor V added a comment -

          Any update on this? Shall we report it on the plugin's page?

           

           

          timja Tim Jacomb added a comment -

          Can you try on 2.271?

          I've attempted to reproduce this on 2.271 and was not able to.

          I could add config files here:
          http://localhost:8086/jenkins/configfiles/

          and I could configure them in a freestyle job just fine and they got copied to the workspace

          I even tried with the above plugins list (although everything on the latest version) and it all worked.

          Can you please provide more details on what isn't working, what steps you are doing.
          Or try updating other plugins as maybe it's something else causing the issue

          Alternatively

          gaborv Gabor V added a comment -

          I have tried v2.271 and the issue is still there. Job configuration pages are broken and managed script files can not be saved.

          Config file provider plugin version: 3.7.0

          Rolling back jenkins to v2.263 which works fine.

          timja Tim Jacomb added a comment -

          Gabor V have you updated all of your plugins? if so can you provide a full plugins list as I can't reproduce this with either config file provider in isolation or the list that Francis provided

          gaborv Gabor V added a comment - - edited

          Tim Jacomb I am back from holidays amd have upgraded the plugins to the latest version and the Jenkins main app as well to v2.273 and the problem is gone. Not sure which update resolved the error.

          timja Tim Jacomb added a comment -

          Thanks for the confirmation! It could have been another plugin breaking it


            People

            Assignee:
            domi Dominik Bartholdi
            Reporter:
            flabrie Francis Labrie
            Votes:
            3 Vote for this issue
            Watchers:
            4 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: