Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-64382

Git tool chooser picks JGit even when submodules are present

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Minor
    • Resolution: Fixed
    • Component/s: git-client-plugin
    • Labels:
      None
    • Environment:
      Git plugin 4.4.0 and later and git client plugin 3.5.1
    • Similar Issues:
    • Released As:
      Git plugin 4.5.1 released 26 Dec 2020

      Description

      To reproduce:

      • make sure JGit is available as Git tool in your setup
      • create a single branch pipeline from https://github.com/zbynek/submodule-grandparent , branch "main"
      • add "advanced submodule behaviors" and either left all checkboxes blank or check only recursive checkout

      Expected:

      • command line git is used and build works

      Actual

      • JGit is used and build fails

      Known workarounds: check some of the other checkboxes or fill in some fields (use parent credentials, max number of threads, ...)

      Notes: the code handles these options one by one source, it may be better to simply disable JGit when the submodule block is present.

        Attachments

          Activity

          ianw Ian Williams added a comment -

          You don't list versions, but review "Performance Improvement: Final Phase and Release" and update.

          zbynek Zbynek Konecny added a comment -

          Ian Williams thanks, yes, this is caused by the performance improvement.


            People

            Assignee:
            markewaite Mark Waite
            Reporter:
            zbynek Zbynek Konecny
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: