Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-64407

Flakes: .git folder missing

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Minor
    • Resolution: Cannot Reproduce
    • Component/s: git-plugin
    • Labels:
      None
    • Environment:
      Latest versions of both git/gerrit plugins
    • Similar Issues:

      Description

      Semi frequently during CI runs (maybe 1 in 100 runs), when trying to use git the following error message is generated

      fatal: not a git repository (or any parent up to mount point /home)

      We can be sure the git repo was actually cloaned since the Jenkinsfile itself was picked up, but it appears that the `.git` directory is missing

        Attachments

          Activity

          markewaite Mark Waite added a comment -

          The Jenkinsfile is cloned to the controller initially so that it can be executed on the controller. If "not a git repository" is being reported from the agent, then there is no git repository on the agent and the Jenkinsfile is not yet available in the agent workspace.

          Closing as not reproducible because I assume it is a local issue with your git server or a local issue with the file system on the agent or a local issue with the agent. I've seen intermittent cases of a git server that refused ssh connections because there were too many requests at one time. I'm sure there are other load conditions which may cause the same failure.

          I checked the many, many build logs on ci.jenkins.io and on my test server and found no cases of that message in any log file. The message does occur in the source code of GitClientTest.java in the git client plugin, but it is only in the test code and test code is not delivered with the plugin.


            People

            Assignee:
            Unassigned Unassigned
            Reporter:
            mrmeku Daniel
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: