Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-64433

Plugin Manager gives vague warning about newer plugins

    XMLWordPrintable

Details

    Description

      On the Jenkins Plugin Manager update list (Manage Jenkins -> Manage Plugins -> Updates tab), sometimes a vague message will appear about plugin updates that can't be installed.

      This version of the plugin exists but it is not being offered as an update. This is typically the case when plugin requirements, e.g. a recent version of Jenkins, are not satisfied. See the plugin documentation for information about its requirements.

      The message looks like a warning, that may require user action to correct, though in practice it may be of little interest, with little the user can do about the situation.

      Although the message hints at a possible reason, it does not provide a clear indication of the problem (or lack there of). Instead, users must visit the plugin page to determine what the plugin requirements are. They must also be aware of additional context to make sense of this, namely:

      • Jenkins version they are running
      • latest Jenkins LTS release
      • latest Jenkins release

      From the above pieces of information they may piece together that they need an update, or that the message is really of little to no interest, and it should be ignored. Getting to that point takes a bit of time though. If all of the information was provided in one place, it would allow a decision to be reached more quickly. In particular, the message could be made to look less like a warning, and more informational, and actually provided the information needed to make a decision.

      Even better, it may be desirable to not present a message, suggesting something may be wrong, when the update is likely to be of little interest. If someone is choosing to run an LTS release of Jenkins, they may desire the stability, and may not be interested in updates that require a non-LTS release of Jenkins. In that case, it may be desirable to not list anything at all. Only plugins that can be installed on their version of Jenkins (or the latest LTS release) are listed.

      If that seems like too little information, perhaps a summary can be provided below the plugin list instead, such as "There are 2 plugin updates available that require an updated version of Jenkins". Couple that with information about their version of Jenkins versus latest and LTS releases may allow people to quickly make decisions and move on.

       

      Attachments

        Activity

          There are no comments yet on this issue.

          People

            Unassigned Unassigned
            dstevens Daniel
            Votes:
            2 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

              Created:
              Updated: