Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-64452

New UI broken with Azure AD matrix-based security

    XMLWordPrintable

    Details

    • Similar Issues:

      Description

      Hello.

      I have Jenkins setup running for a couple of months, with default admin user, several pipelines configured.

      Now I have Azure Active Directory as security realm, and
      Azure Active Directory Matrix-based security, login/logout works fine. 

      I created new empty pipeline, and UI is broken, I can't save changes at all.

      I reverted back to jenkins user database, and admin user, and everything looks fine again. Tried Firefox. Chrome, Edge, but all have same issue.

      After playing around, I figured out it is not Azure AD plugin itself, because if I use 
      Matrix-based security or  Project-based Matrix Authorization Strategy, UI is not broken.
      Ofcourse, this doesn't mean Azure AD plugin is not culprit.

      Here are couple of screenshots, where you can see than with Azure AD matrix based strategy, Disable this project and Quiet period are in upper right corner, all options are, even not checked, are behaving like checked, and pipeline field where you should enter code is missing,

      I have another jenkins instance with older version (with old UI) and all is fine there, this is my first instance with new UI, so must be something related to new version and azure ad plugin.

        Attachments

        1. jenkins admin user 1.jpg
          jenkins admin user 1.jpg
          110 kB
        2. jenkins admin user 2.jpg
          jenkins admin user 2.jpg
          66 kB
        3. jenkins azure ad 1.jpg
          jenkins azure ad 1.jpg
          169 kB
        4. jenkins azure ad 2.jpg
          jenkins azure ad 2.jpg
          129 kB
        5. jenkins azure ad 3.jpg
          jenkins azure ad 3.jpg
          95 kB

          Issue Links

            Activity

            Hide
            vladaurosh Vlad Uros added a comment - - edited

            I've just updated Jenkins to 2.271 as it resolves JENKINS-64072 (Configure UI completely broken after upgrade to 2.264) but issue is still there.

            EDIT:
            Just saw that issue is opened on Github
            https://github.com/jenkinsci/azure-ad-plugin/issues/91

            Show
            vladaurosh Vlad Uros added a comment - - edited I've just updated Jenkins to 2.271 as it resolves JENKINS-64072 (Configure UI completely broken after upgrade to 2.264) but issue is still there. EDIT: Just saw that issue is opened on Github https://github.com/jenkinsci/azure-ad-plugin/issues/91

              People

              Assignee:
              azure_devops Azure DevOps
              Reporter:
              vladaurosh Vlad Uros
              Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: