Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-64514

JGit based polling hangs sometimes on ci.jenkins.io

    XMLWordPrintable

    Details

    • Type: Improvement
    • Status: Closed (View Workflow)
    • Priority: Minor
    • Resolution: Cannot Reproduce
    • Component/s: git-plugin
    • Labels:
      None
    • Environment:
      Jenkins 2.263.1, git plugin 4.5.0, git client plugin 3.5.1 with performance enhancements enabled
    • Similar Issues:

      Description

      The administrative monitor for excessive polling threads is visible on ci.jenkins.io for 6 different repositories that are smaller than 5 MB each. The git plugin chose to poll with JGit and for some reason, JGit polling did not complete.

      I've disabled the git plugin performance improvements on ci.jenkins.io until the issue can be investigated further.

        Attachments

          Activity

          markewaite Mark Waite added a comment -

          The hung polling threads are all from the same time, roughly 6 days ago. It is unclear if the problem was that GitHub was down briefly or that the Jenkins polling threads at that time had some issue. Will be hidden by the next restart of Jenkins when plugins are updated or Jenkins code is updated.


            People

            Assignee:
            Unassigned Unassigned
            Reporter:
            markewaite Mark Waite
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: