Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-64588

Can't save job configuration when using Active choices parameter plugin

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Critical
    • Resolution: Cannot Reproduce
    • Component/s: active-choices-plugin
    • Labels:
      None
    • Environment:
      Jenkins version: 2.274 , Active choices parameter plugin version: 2.5.1
    • Similar Issues:

      Description

      Hi, 

      When a job have a parameter of type "Active choices parameter" we can't save the job configuration from the UI.
      When using the other parameters types like String and Boolean it's ok and we can save.
      This is the error when trying to click Apply (the save button also not working):

      It's critical because we have a job with 'Build periodically with parameters' configuration that we can't change from the UI or from the groovy code.

        Attachments

          Activity

          ioannis Ioannis Moutsatsos added a comment -

          I would say it is a very specific problem to your setup that we need an environment to test. Cannot reproduce it in my environment a Windows 16 server with Jenkins LTS 2.263.1 and Active choices v2.5.1

          ioannis Ioannis Moutsatsos added a comment -

          Also, we currently do not recommend using the plugin with  Jenkins >v2.263.1 LTS Jenkins v 2.264 introduced breaking changes. see JENKINS-62806

          kinow Bruno P. Kinoshita added a comment -

          Hi Maor ,

          I tested two versions of Jenkins, one 2.204.1 and 2.277.1, and I was able to save/load the job configuration with no issues.

          Closing as cannot reproduce, but in case the issue persists, feel free to re-open including information about your environment. Note that we recommend using the latest LTS version as we don't have enough developer bandwidth to maintain compatibility with older versions (though we try to).

          Thanks,

          Bruno


            People

            Assignee:
            kinow Bruno P. Kinoshita
            Reporter:
            maor_t Maor
            Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: