Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-64640

Connect to ALM SaaS via API Key does not work anymore

    XMLWordPrintable

    Details

    • Similar Issues:

      Description

      After upgrading Micro Focus Application Automation Tools plugin from version 6.2 version 6.5 on our jenkins, we are unable to connect to our ALM SaaS instance (version 15.01) using API key.

      Each time we run a job, it failed. When checking the Console Output, we found this error message: "One or more of the required connection parameters is empty." Can someone indicate which parameter is missing? We have populated all the necessary field 

      We have created a new build in jenkins and in the Configuration System page, we have added our SSO credentials and in the build configuration we have selected the checkbox "SSO enable" and selected the "ALM Client ID" to use and also type in the path to the test set and under in which Domain and Project it can be found.  (see attachements).

       

      Multiple projects in our organization are depending of this plugin and right now no one can run there automated tests.

       

      In the version 6.2 of the plugin, we are able to connect to our ALM SaaS instance using API keys but after upgrading to version 6.5 it has stopped working. 

        Attachments

          Activity

          ajroudsami Sami Jansson created issue -
          ajroudsami Sami Jansson made changes -
          Field Original Value New Value
          Attachment Console output plugin version 6.5.PNG [ 53836 ]
          Hide
          ajroudsami Sami Jansson added a comment -

          I have added a screenshot of the console output that display the error message that we got.

          I can send you via mail the paramfile that the build is using, if you want too.

          Show
          ajroudsami Sami Jansson added a comment - I have added a screenshot of the console output that display the error message that we got. I can send you via mail the paramfile that the build is using, if you want too.
          ptofan Paul-Adrian Tofan made changes -
          Assignee Paul-Adrian Tofan [ ptofan ] Roy Lu [ roy_lu ]
          Hide
          ajroudsami Sami Jansson added a comment - - edited

          Hi Roy Lu

          Is there any update regarding this issue?

           

          Br

          Sami

          Show
          ajroudsami Sami Jansson added a comment - - edited Hi Roy Lu Is there any update regarding this issue?   Br Sami
          ptofan Paul-Adrian Tofan made changes -
          Assignee Roy Lu [ roy_lu ] Anda Sorina Laakso [ aslaakso ]
          Hide
          ajroudsami Sami Jansson added a comment -

          please, is there any update on this ticket? we weren't able to execute our test for more than a week. If there are no solution coming out before Tuesday 2020-01-26 then we will have no choice but to stop using Micro Focus since there are obviously not reliable.

           

          /Sami

          Show
          ajroudsami Sami Jansson added a comment - please, is there any update on this ticket? we weren't able to execute our test for more than a week. If there are no solution coming out before Tuesday 2020-01-26 then we will have no choice but to stop using Micro Focus since there are obviously not reliable.   /Sami
          Hide
          aslaakso Anda Sorina Laakso added a comment -

          Hi Sami,

          As a first note and for further usage of the plugin, next time when you encounter an issue which blocks your automation testing processes, please open a CPE with the help of our support engineers. In this way, your ticket will be prioritized over Jira tickets and we can follow up work on the issue easier and establish meetings with you if needed.
          Second item, I will take a look on this problem you are facing, since it is related to the jenkins plugin, so it should be handled by us, not by the ALM team.
          Indeed compared to version 6.2 there has been a major update regarding the ALM credentials: the ALM credentials, both SSO and non-SSO, have been moved to Jenkins Configure System page. I assume you run the "Migrate ALM credentials job" before using them in your ALM job configuration page. Please make sure that you have both ALM Api key secret and ALM Client ID in Jenkins Configure System page and that they are setup properly also in UFT and still working ( both client ID and api key secret are still valid credentials - make a test a login separately with them in ALM).
          If everything is setup correctly and connection with ALM is working outside the Jenkins plugin, we can setup a meeting if you want. Just let me know your availability and preference on Teams or Webex.

          You can also email me directly to: anda-sorina.laakso@microfocus.com.

          Note: send me by email also the param file ( props....txt).

          Here is our updated documentation on using UFT, Jenkins and ALM :

          https://admhelp.microfocus.com/uft/en/15.0-15.0.2/UFT_Help/Content/User_Guide/Jenkins.htm#mt-item-8

          Thank you.

          Show
          aslaakso Anda Sorina Laakso added a comment - Hi Sami, As a first note and for further usage of the plugin, next time when you encounter an issue which blocks your automation testing processes, please open a CPE with the help of our support engineers. In this way, your ticket will be prioritized over Jira tickets and we can follow up work on the issue easier and establish meetings with you if needed. Second item, I will take a look on this problem you are facing, since it is related to the jenkins plugin, so it should be handled by us, not by the ALM team. Indeed compared to version 6.2 there has been a major update regarding the ALM credentials: the ALM credentials, both SSO and non-SSO, have been moved to Jenkins Configure System page. I assume you run the "Migrate ALM credentials job" before using them in your ALM job configuration page. Please make sure that you have both ALM Api key secret and ALM Client ID in Jenkins Configure System page and that they are setup properly also in UFT and still working ( both client ID and api key secret are still valid credentials - make a test a login separately with them in ALM). If everything is setup correctly and connection with ALM is working outside the Jenkins plugin, we can setup a meeting if you want. Just let me know your availability and preference on Teams or Webex. You can also email me directly to: anda-sorina.laakso@microfocus.com. Note: send me by email also the param file ( props....txt). Here is our updated documentation on using UFT, Jenkins and ALM : https://admhelp.microfocus.com/uft/en/15.0-15.0.2/UFT_Help/Content/User_Guide/Jenkins.htm#mt-item-8 Thank you.
          Hide
          ajroudsami Sami Jansson added a comment - - edited

          Hi Sorina

           

          Did you receive the mail that I have send you last week?

           

          Br

          Sami

          Show
          ajroudsami Sami Jansson added a comment - - edited Hi Sorina   Did you receive the mail that I have send you last week?   Br Sami
          Hide
          aslaakso Anda Sorina Laakso added a comment -

          No, I did not receive any email and I was wondering if you have any updates. Please try to resend it. Thank you.

          Show
          aslaakso Anda Sorina Laakso added a comment - No, I did not receive any email and I was wondering if you have any updates. Please try to resend it. Thank you.
          Hide
          ajroudsami Sami Jansson added a comment -

          That is strange, I have send an email on Tuesday, 26 January 2021 at 10:06 am to the mail address that you have mention (anda-sorina.laakso@microfocus.com) with the subject "JENKINS-64640 Connect to ALM SaaS via API Key does not work anymore". I will try to send it again.

           

          The situation have not change, some project are using the old version of the plugin (6.2) since the latest version does not wor for them.

           

           

           

          Show
          ajroudsami Sami Jansson added a comment - That is strange, I have send an email on Tuesday, 26 January 2021 at 10:06 am to the mail address that you have mention (anda-sorina.laakso@microfocus.com) with the subject " JENKINS-64640 Connect to ALM SaaS via API Key does not work anymore". I will try to send it again.   The situation have not change, some project are using the old version of the plugin (6.2) since the latest version does not wor for them.      
          Hide
          aslaakso Anda Sorina Laakso added a comment -

          I just sent you an email on ajroudsami@gmail.com. Let me know if you received it.

          Show
          aslaakso Anda Sorina Laakso added a comment - I just sent you an email on ajroudsami@gmail.com. Let me know if you received it.
          Hide
          ajroudsami Sami Jansson added a comment -

          I have received the email and have send you a respons

           

          /sami

          Show
          ajroudsami Sami Jansson added a comment - I have received the email and have send you a respons   /sami
          Hide
          aslaakso Anda Sorina Laakso added a comment -

          Bug fixed.

          Show
          aslaakso Anda Sorina Laakso added a comment - Bug fixed.
          aslaakso Anda Sorina Laakso made changes -
          Resolution Fixed [ 1 ]
          Status Open [ 1 ] Resolved [ 5 ]
          aslaakso Anda Sorina Laakso made changes -
          Status Resolved [ 5 ] Closed [ 6 ]
          Hide
          ajroudsami Sami Jansson added a comment -

          the issue still occur in version: 6.7 so my question is under which releasing are you going  release this bug fix?

           

           

          Show
          ajroudsami Sami Jansson added a comment - the issue still occur in version: 6.7 so my question is under which releasing are you going  release this bug fix?    
          ajroudsami Sami Jansson made changes -
          Resolution Fixed [ 1 ]
          Status Closed [ 6 ] Reopened [ 4 ]
          Hide
          ajroudsami Sami Jansson added a comment -

          Any updates please....

          Show
          ajroudsami Sami Jansson added a comment - Any updates please....
          Hide
          hildaboth Hilda added a comment -

          Please contact Anda, on  anda-sorina.laakso@microfocus.com e-mail address in order to set up a meeting for this blocking issue.

          Show
          hildaboth Hilda added a comment - Please contact Anda, on  anda-sorina.laakso@microfocus.com  e-mail address in order to set up a meeting for this blocking issue.
          Hide
          ajroudsami Sami Jansson added a comment -

          Hi

          I have already send email to Anda on the 26 mars 2021 but did not get respond, that is why I have reopened this ticket

           

          Br

          Sami 

          Show
          ajroudsami Sami Jansson added a comment - Hi I have already send email to Anda on the 26 mars 2021 but did not get respond, that is why I have reopened this ticket   Br Sami 
          Hide
          1996phani Shanmukha Gajula added a comment - - edited

          Sami Jansson , is your Domain and Project names are correct? make sure they're with the same casing. it is case-sensitive I too saw this problem and I am able to login after fixing that

          you can try this testing it out credentials from https://hostname/qcbin/rest/oauth2/login from postman

          headers - Content-Type : application/json
          body - 

          {"clientId":"apikey-yourkey", "secret":"secret"}

          this is to validate your credentials

          Show
          1996phani Shanmukha Gajula added a comment - - edited Sami Jansson  , is your Domain and Project names are correct? make sure they're with the same casing. it is case-sensitive I too saw this problem and I am able to login after fixing that you can try this testing it out credentials from https://hostname/qcbin/rest/oauth2/login  from postman headers - Content-Type : application/json body -  {"clientId":"apikey-yourkey", "secret":"secret"} this is to validate your credentials
          hildaboth Hilda made changes -
          Assignee Anda Sorina Laakso [ aslaakso ] Hilda [ JIRAUSER131816 ]
          hildaboth Hilda made changes -
          Assignee Hilda [ JIRAUSER131816 ] Anda Sorina Laakso [ aslaakso ]

            People

            Assignee:
            aslaakso Anda Sorina Laakso
            Reporter:
            ajroudsami Sami Jansson
            Votes:
            0 Vote for this issue
            Watchers:
            4 Start watching this issue

              Dates

              Created:
              Updated: