Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-64688

Upgrading Datadog plugin to 2.6.0 breaks Jenkins

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Labels:
      None
    • Environment:
      jenkins-version - 2.263.1
      workflow-job - 2.40
      workflow-api - 2.40
      Datadog-plugin - 2.60.1
    • Similar Issues:

      Description

      Upgrading to Datadog-plugin version 2.60.1 requires the workflow-job plugin to be at least at 2.40 

      After this we witness Jenkins in a zombie state of not able to run builds i.e. via BuildNow, Time triggered, web-hooks. Also to note existing jobs after a graceful restart is stuck and do not continue.
      We see multiple of these in our logs, which is similar to JENKINS-52362 , however rolling back to Datadog-plugin version 1.1 and using workflow-job 2.37 does not create the issue anymore.

      //INFO: Running CpsFlowExecution[Owner[job/branch/build_number]] unresponsive for 3 min 30 sec
      org.jenkinsci.plugins.workflow.support.concurrent.Timeout lambda$ping$0

       

        Attachments

          Activity

          datadog Datadog HQ added a comment -

          Hello - this issue seems similar to one posted to GitHub here: https://github.com/jenkinsci/datadog-plugin/issues/170

          We are posting version 2.8.1 of the Datadog plugin which includes a fix, can you try it out and see if that solves this problem as well?

          akumarmandapati Ajay Kumar added a comment -

          Thanks for letting us know, we will see if this solves our issue.  

          jsimon Julia Simon added a comment -

          Hallo Ajay Kumar did you have a chance to check if it's working?

          jsimon Julia Simon added a comment -

          Halo Ajay Kumar, I'm closing this issue now. Please let us know if you are still experiencing this issue

          akumarmandapati Ajay Kumar added a comment -

          Hey Julia Simon I am extremely sorry for responding late on this one!  I can confirm that the issue is solved now. 
          Thanks!


            People

            Assignee:
            datadog Datadog HQ
            Reporter:
            akumarmandapati Ajay Kumar
            Votes:
            0 Vote for this issue
            Watchers:
            4 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: