Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-64728

Jenkins agent failed to build connection between IBMi V7R4

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Minor
    • Resolution: Not A Defect
    • Component/s: ssh-slaves-plugin
    • Labels:
      None
    • Environment:
      IBMi V7R4
    • Similar Issues:

      Description

      As a Jenkins user and an IBMi developer, I do want to use Jenkins to drive some jobs that running on IBMi V7R4.

      But the agent cannot online and keep launching...

      This is working fine on IBMi V7R1 to V7R3, not sure what cause V7R4 in the bad stage.

      See below log from the agent side:

      Jan 27, 2021 2:03:33 AM hudson.remoting.SynchronousCommandTransport$ReaderThread runJan 27, 2021 2:03:33 AM hudson.remoting.SynchronousCommandTransport$ReaderThread runINFO: I/O error in channel channeljava.io.IOException: Unexpected EOF at hudson.remoting.ChunkedInputStream.readUntilBreak(ChunkedInputStream.java:99) at hudson.remoting.ChunkedCommandTransport.readBlock(ChunkedCommandTransport.java:39) at hudson.remoting.AbstractSynchronousByteArrayCommandTransport.read(AbstractSynchronousByteArrayCommandTransport.java:34) at hudson.remoting.SynchronousCommandTransport$ReaderThread.run(SynchronousCommandTransport.java:63)
      

      See below log from Jenkins side:

      SSHLauncher{host='ACDTST01', port=22, credentialsId='4222aab3-1c59-477d-bd58-6a0268d2b84b', jvmOptions='-Dos.name=AIX', javaPath='/QOpenSys/QIBM/ProdData/OS400/PASE/bin/java', prefixStartSlaveCmd='', suffixStartSlaveCmd='', launchTimeoutSeconds=60, maxNumRetries=10, retryWaitTime=15, sshHostKeyVerificationStrategy=hudson.plugins.sshslaves.verifiers.NonVerifyingKeyVerificationStrategy, tcpNoDelay=false, trackCredentials=true}SSHLauncher{host='ACDTST01', port=22, credentialsId='4222aab3-1c59-477d-bd58-6a0268d2b84b', jvmOptions='-Dos.name=AIX', javaPath='/QOpenSys/QIBM/ProdData/OS400/PASE/bin/java', prefixStartSlaveCmd='', suffixStartSlaveCmd='', launchTimeoutSeconds=60, maxNumRetries=10, retryWaitTime=15, sshHostKeyVerificationStrategy=hudson.plugins.sshslaves.verifiers.NonVerifyingKeyVerificationStrategy, tcpNoDelay=false, trackCredentials=true}[01/27/21 18:32:40] [SSH] Opening SSH connection to ACDTST01:22.[01/27/21 18:32:41] [SSH] WARNING: SSH Host Keys are not being verified. Man-in-the-middle attacks may be possible against this connection.[01/27/21 18:32:41] [SSH] Authentication successful.[01/27/21 18:32:41] [SSH] The remote user's environment is:HOME=/home/TSTADMINIFS=  
      LOGIN=tstadminLOGNAME=tstadminMAIL=/var/spool/mail/tstadminMAILCHECK=600OPTIND=1PATH=/QOpenSys/usr/bin:/usr/ccs/bin:/QOpenSys/usr/bin/X11:/usr/sbin:.:/usr/binSHELL=/QOpenSys/usr/bin/bshSSH_CLIENT=10.117.17.71 55786 22SSH_CONNECTION=10.117.17.71 55786 10.17.8.248 22TZ=<PST>8<PDT>,M4.1.0,M10.5.0USER=tstadmin[01/27/21 18:32:41] [SSH] Starting sftp client.[01/27/21 18:32:41] [SSH] Copying latest remoting.jar...Source agent hash is D866F0B482DB94F38E49B26B465D5DB5. Installed agent hash is D866F0B482DB94F38E49B26B465D5DB5Verified agent jar. No update is necessary.Expanded the channel window size to 4MB[01/27/21 18:32:41] [SSH] Starting agent process: cd "/home/tstadmin" && /QOpenSys/QIBM/ProdData/OS400/PASE/bin/java -Dos.name=AIX -jar remoting.jar -workDir /home/tstadmin -jar-cache /home/tstadmin/remoting/jarCacheJan 27, 2021 2:32:43 AM org.jenkinsci.remoting.engine.WorkDirManager initializeWorkDirINFO: Using /home/tstadmin/remoting as a remoting work directoryJan 27, 2021 2:32:43 AM org.jenkinsci.remoting.engine.WorkDirManager setupLoggingINFO: Both error and output logs will be printed to /home/tstadmin/remotingWARNING: Are you running agent from an interactive console?If so, you are probably using it incorrectly.See https://wiki.jenkins.io/display/JENKINS/Launching+agent+from+console<===[JENKINS REMOTING CAPACITY]===>channel started
      

      From IBMi SSH size, we could see the process:

       qsecofr 163424 163260   0 02:32:40      -  0:00 /QOpenSys/QIBM/ProdData/SC1/OpenSSH/sbin/sshd -R
      tstadmin 163431 163424   0 02:32:41      -  0:00 bsh bsh bsh
      tstadmin 163432 163431   0 02:32:42      -  0:00 /QOpenSys/QIBM/ProdData/OS400/PASE/bin/java -Dos.name=AIX -jar remoting.jar -workDir /home/tstadmin
      tstadmin 163433 163432   0 02:32:42      -  0:01 /QOpenSys/QIBM/ProdData/JavaVM/jdk80/64bit/jre/lib/ppc64/jvmStartPase 1816
      

      My jenkins node setup as below:

       

        Attachments

          Activity

          ifernandezcalvo Ivan Fernandez Calvo added a comment -

          The channel is started, it should be more exceptions in logs, Check the files in /home/tstadmin/remoting, see [common-info-needed-to-troubleshooting-a-bug](https://github.com/jenkinsci/ssh-slaves-plugin/blob/master/doc/TROUBLESHOOTING.md#common-info-needed-to-troubleshooting-a-bug) in any case I think this is not a bug is more a support request, so please use the google groups for that [Hoe to report an issue](https://www.jenkins.io/participate/report-issue/)


            People

            Assignee:
            Unassigned Unassigned
            Reporter:
            boykazhu Boyka Zhu
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: