Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-6480

Slave windows service error timeout 1053 on Windows 2003

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Cannot Reproduce
    • Component/s: core
    • Labels:
    • Environment:
      Windows 2003,Tomcat 6
    • Similar Issues:

      Description

      Can start a slave from the Dos command prompt using the information from

      http://wiki.jenkins-ci.org/display/JENKINS/Distributed+builds

      When try and make it a Windows Service it starts and will respond to jobs queued up needing an executor. Windows never thinks it finishes staring up and kills process. Windows reports a Error 1053: The service did not respond to the start or control request in a timely fashion.

      The Windows error Log says nothing useful timeout after 30 seconds waiting for service to connect.

      Snippet of hudson slave error log

      This is a Windows slave
      Copied maven-agent.jar
      Copied maven-interceptor.jar
      Copied maven2.1-interceptor.jar
      Slave successfully connected and online
      ERROR: ticibuild-slave-a: ticibuild-slave-a
      [8mha:AAAAWB+LCAAAAAAAAABb85aBtbiIQSmjNKU4P08vOT+vOD8nVc8DzHWtSE4tKMnMz/PLL0ldFVf2c+b/lb5MDAwVRQxSaBqcITRIIQMEMIIUFgAAckCEiWAAAAA=[0mjava.net.UnknownHostException: ticibuild-slave-a: ticibuild-slave-a
      at java.net.InetAddress.getAllByName0(InetAddress.java:1145)
      at java.net.InetAddress.getAllByName(InetAddress.java:1072)
      at java.net.InetAddress.getAllByName(InetAddress.java:1008)
      at java.net.InetAddress.getByName(InetAddress.java:958)
      at org.jinterop.dcom.core.JIComServer.<init>(JIComServer.java:425)
      at org.jvnet.hudson.wmi.WMI.connect(WMI.java:41)
      at hudson.os.windows.ManagedWindowsServiceLauncher.afterDisconnect(ManagedWindowsServiceLauncher.java:273)
      at hudson.slaves.SlaveComputer$2.onClosed(SlaveComputer.java:304)
      at hudson.remoting.Channel.terminate(Channel.java:613)
      at hudson.remoting.Channel$ReaderThread.run(Channel.java:880)

        Attachments

          Activity

          onekilo79 onekilo79 added a comment - - edited

          Log from Java

          <?xml version="1.0" encoding="windows-1252" standalone="no"?>
          <!DOCTYPE log SYSTEM "logger.dtd">
          <log>
          <record>
          <date>2010-05-17T19:54:00</date>
          <millis>1274122440986</millis>
          <sequence>0</sequence>
          <logger>hudson.remoting.jnlp.Main</logger>
          <level>INFO</level>
          <class>hudson.remoting.jnlp.Main$CuiListener</class>
          <method><init></method>
          <thread>10</thread>
          <message>Hudson agent is running in headless mode.</message>
          </record>
          <record>
          <date>2010-05-17T19:54:01</date>
          <millis>1274122441033</millis>
          <sequence>1</sequence>
          <logger>hudson.remoting.jnlp.Main</logger>
          <level>INFO</level>
          <class>hudson.remoting.jnlp.Main$CuiListener</class>
          <method>status</method>
          <thread>11</thread>
          <message>Locating server among http://host/hudson/, http://host/hudson/</message>
          </record>
          <record>
          <date>2010-05-17T19:54:01</date>
          <millis>1274122441033</millis>
          <sequence>2</sequence>
          <logger>hudson.remoting.jnlp.Main</logger>
          <level>INFO</level>
          <class>hudson.remoting.jnlp.Main$CuiListener</class>
          <method>status</method>
          <thread>11</thread>
          <message>Connecting to 10.80.52.11:2765</message>
          </record>
          <record>
          <date>2010-05-17T19:54:01</date>
          <millis>1274122441033</millis>
          <sequence>3</sequence>
          <logger>hudson.remoting.jnlp.Main</logger>
          <level>INFO</level>
          <class>hudson.remoting.jnlp.Main$CuiListener</class>
          <method>status</method>
          <thread>11</thread>
          <message>Handshaking</message>
          </record>
          <record>
          <date>2010-05-17T19:54:01</date>
          <millis>1274122441064</millis>
          <sequence>4</sequence>
          <logger>hudson.remoting.jnlp.Main</logger>
          <level>INFO</level>
          <class>hudson.remoting.jnlp.Main$CuiListener</class>
          <method>status</method>
          <thread>11</thread>
          <message>Connected</message>
          </record>
          <record>
          <date>2010-05-17T19:54:01</date>
          <millis>1274122441814</millis>
          <sequence>5</sequence>
          <logger>com.youdevise.hudson.slavestatus.SlaveListener</logger>
          <level>INFO</level>
          <class>com.youdevise.hudson.slavestatus.SlaveListener</class>
          <method>call</method>
          <thread>12</thread>
          <message>Slave-status listener starting</message>
          </record>
          <record>
          <date>2010-05-17T19:54:01</date>
          <millis>1274122441877</millis>
          <sequence>6</sequence>
          <logger>com.youdevise.hudson.slavestatus.SlaveListener</logger>
          <level>INFO</level>
          <class>com.youdevise.hudson.slavestatus.SocketHTTPListener</class>
          <method>waitForConnection</method>
          <thread>12</thread>
          <message>Slave-status listener ready on port 3141</message>
          </record>

          onekilo79 onekilo79 added a comment -

          Using the following download from microsoft
          http://technet.microsoft.com/en-us/sysinternals/bb896645.aspx
          Filtering upon tomcat or hudson

          The last jar called from the slave is the maven2.1-interceptor.jar

          onekilo79 onekilo79 added a comment -

          Full xml log from watching processes via the process monitor from sysinternals.com of the classes and jars hit. This is the log when the windows service is started and times out.

          andreyevbr andreyevbr added a comment -

          @onekilo79 we are having some troubles with ms-w2k3 clients/slaves too.

          Did you followed instructions on http://asimilatorul.com/index.php/2010/05/04/install-hudson-as-a-windows-service/ to setup you client/slave?

          Your master/server run on a linux/unix box? You java process open a lot of sock with "can't identify protocol" name?

          onekilo79 onekilo79 added a comment -

          The master is Win 2003. The slaves are Win 2003.

          I also tried using a slave running Win Xp contacting the Win 2003 slave does the same. Connects but windows thinks it times out and kills it.

          oleg_nenashev Oleg Nenashev added a comment -

          I am closing it, because there was no activity since 2010. It has to be reproduced and reported on new environments


            People

            Assignee:
            Unassigned Unassigned
            Reporter:
            onekilo79 onekilo79
            Votes:
            2 Vote for this issue
            Watchers:
            3 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: