Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-64868

"Unable to connect to Jenkins" during initial setup through wizard.

    XMLWordPrintable

Details

    • Bug
    • Status: Closed (View Workflow)
    • Blocker
    • Resolution: Duplicate
    • core
    • None
    • Jenkins 2.263.4 LTS
      openjdk-11
      Ubuntu 18.04 LTS
      Firefox latest

    Description

      Freshly installed Jenkins returns an error "Unable to connect to Jenkins" after chosing "Install suggested plugins" during initial setup through wizard.
      The server is able to reach https://updates.jenkins.io/current/update-center.json and http://updates.jenkins-ci.org/update-center.json (the former configured by default)

      Also I've tried latest weekly build and jenkins:jenkins docker container an always got the same behaviour

      Upd: Stacktrace (/var/log/jenkins/jenkins.log) can be found here: https://pastebin.com/nJ9XzbJY

      Upd2: `--httpKeepAliveTimeout=60000` "removes" the exception, but wizard still isn't working and returns an error as indicated above

       

      It's a duplicate of https://issues.jenkins.io/browse/JENKINS-46776 but I've decided to create a new issue to attract attention.

      In my case RTT of request was about 1.76min (firefox stats). I understand that such problem caused because of slow VPN and ugly server, but that blocks installation process without any explaniations

      Attachments

        Issue Links

          Activity

            markewaite Mark Waite added a comment -

            We close duplicate issues as "duplicate". You're welcome to vote on the other issue as a way to express your desire that someone should volunteer their time to test all the places where Jenkins might fail over a low bandwidth or high latency network connection.

            A round trip time of over 100 seconds seems like it will cause many different components of Jenkins (Blue Ocean, plugin manager, etc.) to fail.

            markewaite Mark Waite added a comment - We close duplicate issues as "duplicate". You're welcome to vote on the other issue as a way to express your desire that someone should volunteer their time to test all the places where Jenkins might fail over a low bandwidth or high latency network connection. A round trip time of over 100 seconds seems like it will cause many different components of Jenkins (Blue Ocean, plugin manager, etc.) to fail.

            People

              Unassigned Unassigned
              ech0_py ech0
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: