Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-64933

Configure Systems - Apply and Save not working with tomcat

    XMLWordPrintable

Details

    • Bug
    • Status: Open (View Workflow)
    • Blocker
    • Resolution: Unresolved
    • core
    • Jenkins version is 2.263.1-LTS
      Java Version - openjdk version "1.8.0_275"
      OS - CentOS -8.2
      Apache-tomcat-9.0.30
      Reverse proxy running in-front of Jenkins.

    Description

       Under Manage Jenkins --> Configure Systems section, if i click apply or save button it shows below error on browser(Firefox, Chrome). I cannot Apply (Or) Save any configuration due to below errors.

      HTTP Status 403 – Forbidden

      Type Status Report

      Message No valid crumb was included in the request

      Description The server understood the request but refuses to authorize it. Apache Tomcat/9.0.30

       Do i need to add any additional configuration in my tomcat side? Please let me know.

       

      Attachments

        1. 2.png
          2.png
          9 kB
        2. 1.png
          1.png
          4 kB

        Activity

          smohan08 Mohan added a comment - - edited

          We have been running our jenkins under tomcat for last 10 years until we upgrade our jenkins from 2.235.5 (LTS) to 2.263.1-LTS we had no issue.

          Sure we will consider to move out of tomcat.

          Nginx reverse proxy side seems no issues, because i have tested without nginx reverse proxy even in that too facing same problem.

          it looks CSRF is causing issue with tomcat. still digging. hopefully will sorted out.

           

          smohan08 Mohan added a comment - - edited We have been running our jenkins under tomcat for last 10 years until we upgrade our jenkins from 2.235.5 (LTS) to 2.263.1-LTS we had no issue. Sure we will consider to move out of tomcat. Nginx reverse proxy side seems no issues, because i have tested without nginx reverse proxy even in that too facing same problem. it looks CSRF is causing issue with tomcat. still digging. hopefully will sorted out.  
          smohan08 Mohan added a comment - - edited

          Tested with Jenkins - 2.235.5-LTS and with same version of apache-tomcat-9.0.43 here there is no issue.

          smohan08 Mohan added a comment - - edited Tested with Jenkins - 2.235.5-LTS and with same version of apache-tomcat-9.0.43 here there is no issue.
          degasuresh Suresh Dega added a comment -

          Hi Mohan,

          Is this issue is resolved..? Please let me know what is the fix for this...?I'm facing same issue. It will great helpfull if you provide the solution..

          degasuresh Suresh Dega added a comment - Hi Mohan, Is this issue is resolved..? Please let me know what is the fix for this...?I'm facing same issue. It will great helpfull if you provide the solution..
          dee_user Deepa TP added a comment -

          Hi Mohan,

           

          Is this issue resolved? if yes, please provide the solution. even am facing the same issue. It is taking lots of time to fix and am not understanding the root cause for this. This has been a blocker in the production environment,

          dee_user Deepa TP added a comment - Hi Mohan,   Is this issue resolved? if yes, please provide the solution. even am facing the same issue. It is taking lots of time to fix and am not understanding the root cause for this. This has been a blocker in the production environment,
          smohan08 Mohan added a comment -

          Hi Suresh & Deepa, I have solved my problem by moving my Jenkins outside of Apache.

          smohan08 Mohan added a comment - Hi Suresh & Deepa, I have solved my problem by moving my Jenkins outside of Apache.

          People

            Unassigned Unassigned
            smohan08 Mohan
            Votes:
            0 Vote for this issue
            Watchers:
            4 Start watching this issue

            Dates

              Created:
              Updated: