Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-65079

Hudson remoting is failing with Invalid object ID 262 iota=263

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Critical
    • Resolution: Won't Fix
    • Component/s: remoting
    • Labels:
      None
    • Environment:
      Linux Agents
    • Similar Issues:

      Description

      I am using Jenkins core version 2.235.2 and remoting 4.3.

      I am getting the below error intermittently 

      07:26:04 Caused by: java.util.concurrent.ExecutionException: Invalid object ID 262 iota=263

      07:26:04 at hudson.remoting.ExportTable.diagnoseInvalidObjectId(ExportTable.java:478)

      07:26:04 at hudson.remoting.ExportTable.get(ExportTable.java:397)

      07:26:04 at hudson.remoting.Channel.getExportedObject(Channel.java:823)

      07:26:04 at hudson.remoting.RemoteInvocationHandler$RPCRequest.perform(RemoteInvocationHandler.java:922)

      07:26:04 at hudson.remoting.RemoteInvocationHandler$RPCRequest.call(RemoteInvocationHandler.java:905)

      07:26:04 at hudson.remoting.RemoteInvocationHandler$RPCRequest.call(RemoteInvocationHandler.java:857)

      07:26:04 at hudson.remoting.UserRequest.perform(UserRequest.java:211)

      07:26:04 at hudson.remoting.UserRequest.perform(UserRequest.java:54)

      07:26:04 at hudson.remoting.Request$2.run(Request.java:369)

      07:26:04 at hudson.remoting.InterceptingExecutorService$1.call(InterceptingExecutorService.java:72)

      07:26:04 at java.util.concurrent.FutureTask.run(FutureTask.java:266)

      07:26:04 at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)

      07:26:04 at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)

      07:26:04 at hudson.remoting.Engine$1.lambda$newThread$0(Engine.java:117)

      07:26:04 at java.lang.Thread.run(Thread.java:748)

      07:26:04 Suppressed: hudson.remoting.Channel$CallSiteStackTrace: Remote call to JNLP4-connect connection from <Agent id>

      07:26:04 at hudson.remoting.Channel.attachCallSiteStackTrace(Channel.java:1788)

      07:26:04 at hudson.remoting.UserRequest$ExceptionResponse.retrieve(UserRequest.java:356)

      07:26:04 at hudson.remoting.Channel.call(Channel.java:998)

      07:26:04 at hudson.remoting.RemoteInvocationHandler.invoke(RemoteInvocationHandler.java:285)

      07:26:04 at com.sun.proxy.$Proxy128.clean(Unknown Source)

      07:26:04 at org.jenkinsci.plugins.gitclient.RemoteGitImpl.clean(RemoteGitImpl.java:469)

      07:26:04 ...

      07:26:04 at java.util.concurrent.CompletableFuture$AsyncSupply.run(CompletableFuture.java:1590)

      07:26:04 at java.util.concurrent.CompletableFuture$AsyncSupply.exec(CompletableFuture.java:1582)

      07:26:04 at java.util.concurrent.ForkJoinTask.doExec(ForkJoinTask.java:289)

      07:26:04 at java.util.concurrent.ForkJoinPool$WorkQueue.runTask(ForkJoinPool.java:1056)

      07:26:04 at java.util.concurrent.ForkJoinPool.runWorker(ForkJoinPool.java:1692)

      07:26:04 at java.util.concurrent.ForkJoinWorkerThread.run(ForkJoinWorkerThread.java:157)

      07:26:04 Caused by: java.lang.Exception: Object was recently deallocated

      07:26:04     #262 (ref.0) : object=null type=hudson.plugins.git.GitAPI interfaces=[hudson.plugins.git.IGitAPI]

      07:26:04       Created at Thu Mar 04 01:19:47 UTC 2021

      07:26:04     at hudson.remoting.ExportTable$Entry.<init>(ExportTable.java:114)

      07:26:04     at hudson.remoting.ExportTable.export(ExportTable.java:365)

      07:26:04     at hudson.remoting.Channel.internalExport(Channel.java:819)

      07:26:04     at hudson.remoting.Channel.export(Channel.java:810)

      07:26:04     at hudson.remoting.Channel.export(Channel.java:774)

      07:26:04     at org.jenkinsci.plugins.gitclient.LegacyCompatibleGitAPIImpl.writeReplace(LegacyCompatibleGitAPIImpl.java:204)

      07:26:04     at sun.reflect.GeneratedMethodAccessor89.invoke(Unknown Source)

      07:26:04     at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)

      07:26:04     at java.lang.reflect.Method.invoke(Method.java:498)

      07:26:04     at java.io.ObjectStreamClass.invokeWriteReplace(ObjectStreamClass.java:1118)

      07:26:04     at java.io.ObjectOutputStream.writeObject0(ObjectOutputStream.java:1136)

      07:26:04     at java.io.ObjectOutputStream.writeObject(ObjectOutputStream.java:348)

      07:26:04     at hudson.remoting.UserRequest._serialize(UserRequest.java:263)

      07:26:04     at hudson.remoting.UserRequest.serialize(UserRequest.java:272)

      07:26:04     at hudson.remoting.UserRequest.perform(UserRequest.java:222)

      07:26:04     at hudson.remoting.UserRequest.perform(UserRequest.java:54)

      07:26:04     at hudson.remoting.Request$2.run(Request.java:369)

      07:26:04     at hudson.remoting.InterceptingExecutorService$1.call(InterceptingExecutorService.java:72)

      07:26:04     at java.util.concurrent.FutureTask.run(FutureTask.java:266)

      07:26:04     at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)

      07:26:04     at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)

      07:26:04     at hudson.remoting.Engine$1.lambda$newThread$0(Engine.java:117)

      07:26:04     at java.lang.Thread.run(Thread.java:748)

      07:26:04       Released at Thu Mar 04 01:19:48 UTC 2021

      07:26:04     at hudson.remoting.ExportTable$Entry.release(ExportTable.java:163)

      07:26:04     at hudson.remoting.ExportTable.unexportByOid(ExportTable.java:521)

      07:26:04     at hudson.remoting.Channel.unexport(Channel.java:846)

      07:26:04     at hudson.remoting.Channel.unexport(Channel.java:836)

      07:26:04     at hudson.remoting.UnexportCommand.execute(UnexportCommand.java:49)

      07:26:04     at hudson.remoting.Channel$1.handle(Channel.java:606)

      07:26:04     at hudson.remoting.AbstractByteBufferCommandTransport.processCommand(AbstractByteBufferCommandTransport.java:203)

      07:26:04     at hudson.remoting.AbstractByteBufferCommandTransport.receive(AbstractByteBufferCommandTransport.java:189)

      07:26:04     at org.jenkinsci.remoting.protocol.impl.ChannelApplicationLayer.onRead(ChannelApplicationLayer.java:187)

      07:26:04     at org.jenkinsci.remoting.protocol.ApplicationLayer.onRecv(ApplicationLayer.java:206)

      07:26:04     at org.jenkinsci.remoting.protocol.ProtocolStack$Ptr.onRecv(ProtocolStack.java:668)

      07:26:04     at org.jenkinsci.remoting.protocol.impl.SSLEngineFilterLayer.processRead(SSLEngineFilterLayer.java:369)

      07:26:04     at org.jenkinsci.remoting.protocol.impl.SSLEngineFilterLayer.onRecv(SSLEngineFilterLayer.java:117)

      07:26:04     at org.jenkinsci.remoting.protocol.ProtocolStack$Ptr.onRecv(ProtocolStack.java:668)

      07:26:04     at org.jenkinsci.remoting.protocol.NetworkLayer.onRead(NetworkLayer.java:136)

      07:26:04     at org.jenkinsci.remoting.protocol.impl.BIONetworkLayer.access$2200(BIONetworkLayer.java:48)

      07:26:04     at org.jenkinsci.remoting.protocol.impl.BIONetworkLayer$Reader.run(BIONetworkLayer.java:283)

      07:26:04     at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)

      07:26:04     at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)

      07:26:04     at hudson.remoting.Engine$1.lambda$newThread$0(Engine.java:117)

      07:26:04     at java.lang.Thread.run(Thread.java:748)

      07:26:04     Caused by: Command Unexport created at

      07:26:04     at hudson.remoting.Command.<init>(Command.java:81)

      07:26:04     at hudson.remoting.Command.<init>(Command.java:64)

      07:26:04     at hudson.remoting.UnexportCommand.<init>(UnexportCommand.java:35)

      07:26:04     at hudson.remoting.RemoteInvocationHandler$PhantomReferenceImpl.cleanup(RemoteInvocationHandler.java:395)

      07:26:04     at hudson.remoting.RemoteInvocationHandler$PhantomReferenceImpl.access$1000(RemoteInvocationHandler.java:354)

      07:26:04     at hudson.remoting.RemoteInvocationHandler$Unexporter.run(RemoteInvocationHandler.java:612)

      07:26:04     at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)

      07:26:04     at java.util.concurrent.FutureTask.run(FutureTask.java:266)

      07:26:04     at hudson.remoting.AtmostOneThreadExecutor$Worker.run(AtmostOneThreadExecutor.java:111)

      07:26:04     ... 1 more

      07:26:04     Caused by: java.lang.Exception: Proxy hudson.remoting.RemoteInvocationHandler@106 was created for interface hudson.plugins.git.IGitAPI

      07:26:04     at hudson.remoting.RemoteInvocationHandler.<init>(RemoteInvocationHandler.java:144)

      07:26:04     at hudson.remoting.RemoteInvocationHandler.wrap(RemoteInvocationHandler.java:163)

      07:26:04     at hudson.remoting.Channel.export(Channel.java:811)

      07:26:04     at hudson.remoting.Channel.export(Channel.java:774)

      07:26:04     at org.jenkinsci.plugins.gitclient.LegacyCompatibleGitAPIImpl.writeReplace(LegacyCompatibleGitAPIImpl.java:204)

      07:26:04     at sun.reflect.GeneratedMethodAccessor89.invoke(Unknown Source)

      07:26:04     at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)

      07:26:04     at java.lang.reflect.Method.invoke(Method.java:498)

      07:26:04     at java.io.ObjectStreamClass.invokeWriteReplace(ObjectStreamClass.java:1118)

      07:26:04     at java.io.ObjectOutputStream.writeObject0(ObjectOutputStream.java:1136)

      07:26:04     at java.io.ObjectOutputStream.writeObject(ObjectOutputStream.java:348)

      07:26:04     at hudson.remoting.UserRequest._serialize(UserRequest.java:263)

      07:26:04     at hudson.remoting.UserRequest.serialize(UserRequest.java:272)

      07:26:04     at hudson.remoting.UserRequest.perform(UserRequest.java:222)

      07:26:04     at hudson.remoting.UserRequest.perform(UserRequest.java:54)

      07:26:04     at hudson.remoting.Request$2.run(Request.java:369)

      07:26:04     at hudson.remoting.InterceptingExecutorService$1.call(InterceptingExecutorService.java:72)

      07:26:04     at java.util.concurrent.FutureTask.run(FutureTask.java:266)

      07:26:04     at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)

      07:26:04     at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)

      07:26:04     at hudson.remoting.Engine$1.lambda$newThread$0(Engine.java:117)

      07:26:04     ... 1 more

      07:26:04 at hudson.remoting.ExportTable.diagnoseInvalidObjectId(ExportTable.java:468)

      07:26:04 ... 14 more

      07:26:04 Caused by:   Released at Thu Mar 04 01:19:48 GMT 2021

      07:26:04 at hudson.remoting.ExportTable$Entry.release(ExportTable.java:163)

      07:26:04 at hudson.remoting.ExportTable.unexportByOid(ExportTable.java:521)

      07:26:04 at hudson.remoting.Channel.unexport(Channel.java:846)

      07:26:04 at hudson.remoting.Channel.unexport(Channel.java:836)

      07:26:04 at hudson.remoting.UnexportCommand.execute(UnexportCommand.java:49)

      07:26:04 at hudson.remoting.Channel$1.handle(Channel.java:606)

      07:26:04 at hudson.remoting.AbstractByteBufferCommandTransport.processCommand(AbstractByteBufferCommandTransport.java:203)

      07:26:04 at hudson.remoting.AbstractByteBufferCommandTransport.receive(AbstractByteBufferCommandTransport.java:189)

      07:26:04 at org.jenkinsci.remoting.protocol.impl.ChannelApplicationLayer.onRead(ChannelApplicationLayer.java:187)

      07:26:04 at org.jenkinsci.remoting.protocol.ApplicationLayer.onRecv(ApplicationLayer.java:206)

      07:26:04 at org.jenkinsci.remoting.protocol.ProtocolStack$Ptr.onRecv(ProtocolStack.java:668)

      07:26:04 at org.jenkinsci.remoting.protocol.impl.SSLEngineFilterLayer.processRead(SSLEngineFilterLayer.java:369)

      07:26:04 at org.jenkinsci.remoting.protocol.impl.SSLEngineFilterLayer.onRecv(SSLEngineFilterLayer.java:117)

      07:26:04 at org.jenkinsci.remoting.protocol.ProtocolStack$Ptr.onRecv(ProtocolStack.java:668)

      07:26:04 at org.jenkinsci.remoting.protocol.NetworkLayer.onRead(NetworkLayer.java:136)

      07:26:04 at org.jenkinsci.remoting.protocol.impl.BIONetworkLayer.access$2200(BIONetworkLayer.java:48)

      07:26:04 at org.jenkinsci.remoting.protocol.impl.BIONetworkLayer$Reader.run(BIONetworkLayer.java:283)

      07:26:04 ... 4 more

      07:26:04 Caused by: Command Unexport created at

      07:26:04 at hudson.remoting.Command.<init>(Command.java:81)

      07:26:04 at hudson.remoting.Command.<init>(Command.java:64)

      07:26:04 at hudson.remoting.UnexportCommand.<init>(UnexportCommand.java:35)

      07:26:04 at hudson.remoting.RemoteInvocationHandler$PhantomReferenceImpl.cleanup(RemoteInvocationHandler.java:395)

      07:26:04 at hudson.remoting.RemoteInvocationHandler$PhantomReferenceImpl.access$1000(RemoteInvocationHandler.java:354)

      07:26:04 at hudson.remoting.RemoteInvocationHandler$Unexporter.run(RemoteInvocationHandler.java:612)

      07:26:04 at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)

      07:26:04 at java.util.concurrent.FutureTask.run(FutureTask.java:266)

      07:26:04 at hudson.remoting.AtmostOneThreadExecutor$Worker.run(AtmostOneThreadExecutor.java:111)

      07:26:04 ... 1 more

      07:26:04 Caused by: java.lang.Exception: Proxy hudson.remoting.RemoteInvocationHandler@106 was created for interface hudson.plugins.git.IGitAPI

      07:26:04 at hudson.remoting.RemoteInvocationHandler.<init>(RemoteInvocationHandler.java:144)

      07:26:04 at hudson.remoting.RemoteInvocationHandler.wrap(RemoteInvocationHandler.java:163)

      07:26:04 at hudson.remoting.Channel.export(Channel.java:811)

      07:26:04 at hudson.remoting.Channel.export(Channel.java:774)

      07:26:04 at org.jenkinsci.plugins.gitclient.LegacyCompatibleGitAPIImpl.writeReplace(LegacyCompatibleGitAPIImpl.java:204)

      07:26:04 at sun.reflect.GeneratedMethodAccessor89.invoke(Unknown Source)

      07:26:04 at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)

      07:26:04 at java.lang.reflect.Method.invoke(Method.java:498)

      07:26:04 at java.io.ObjectStreamClass.invokeWriteReplace(ObjectStreamClass.java:1118)

      07:26:04 at java.io.ObjectOutputStream.writeObject0(ObjectOutputStream.java:1136)

      07:26:04 at java.io.ObjectOutputStream.writeObject(ObjectOutputStream.java:348)

      07:26:04 at hudson.remoting.UserRequest._serialize(UserRequest.java:263)

      07:26:04 at hudson.remoting.UserRequest.serialize(UserRequest.java:272)

      07:26:04 at hudson.remoting.UserRequest.perform(UserRequest.java:222)

      07:26:04 at hudson.remoting.UserRequest.perform(UserRequest.java:54)

      07:26:04 at hudson.remoting.Request$2.run(Request.java:369)

      07:26:04 at hudson.remoting.InterceptingExecutorService$1.call(InterceptingExecutorService.java:72)

      07:26:04 at java.util.concurrent.FutureTask.run(FutureTask.java:266)

      07:26:04 at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)

      07:26:04 at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)

      07:26:04 at hudson.remoting.Engine$1.lambda$newThread$0(Engine.java:117)

      07:26:04 ... 1 more

       

       

      as per https://issues.jenkins.io/browse/JENKINS-23271 it is resolved. But in core 2.235.3 we are getting this. Is anyone facing it? Any plugin fix requiired?

        Attachments

          Activity

          jthompson Jeff Thompson added a comment -

          I don't have any information on why this might have started occurring. I haven't seen any other recent reports.

          There's not a lot of information here to troubleshot from in this report. If you can narrow it down in any way that would help. Does it always occur with a specific plugin or operation like with that previous issue?

          danielbeck Daniel Beck added a comment -

          I am using Jenkins core version 2.235.2 and remoting 4.3.

          Please update Jenkins, you're already missing out on almost a year of improvements.


            People

            Assignee:
            jthompson Jeff Thompson
            Reporter:
            moumita1981 Moumita
            Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: