Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-651

Status says failed, but all modules are OK

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: maven-plugin
    • Labels:
      None
    • Environment:
      Platform: All, OS: All
    • Similar Issues:

      Description

      We have a number of top-level Hudson maven 2 jobs, each containing several Maven
      2 projects. Building a project will often cause another project in a different
      top-level job to be built (without rebuilding the whole job itself).

      If building this second project fails, then both its status indicator and the
      indicator for its parent top-level job go red to indicate failure (correct).

      But, when the problem is fixed and the module is built again, the top-level
      indicator doesn't go blue again.

      Therefore, over time, we end up with lots of "failed" top-level jobs which, when
      you investigate, turn out to contain only successful child jobs!

      It would be good if a job indicator only showed failure if:

      • The most recent build of the job itself failed, or
      • The most recent build of any child job failed

      Thanks,

        Attachments

          Activity

          kohsuke Kohsuke Kawaguchi added a comment -

          Fixed in 1.121.


            People

            Assignee:
            Unassigned Unassigned
            Reporter:
            tal tal
            Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: