Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-65141

Cannot save workspace cleanup settings in job configuration

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Duplicate
    • Component/s: tfs-plugin
    • Environment:
    • Similar Issues:

      Description

      If I select the 'Delete workspace before build starts' checkbox under 'Build Environment' for a new job configuration (with or without advanced parameters), the checkbox gets deselected upon job creation.

      Similarly, if I select the 'Delete workspace before build starts' checkbox under 'Build Environment' for an existing job (with or without advanced parameters), the checkbox gets deselected upon saving (using either the 'Save' or 'Apply' buttons, though the 'Apply' results in an apparently successful save until refreshing).

       

      This fails silently. (i.e. I don't see anything in the Jenkins system logs indicating something went wrong)

      I'm not sure when exactly this became an issue because it has been a while since we've had to add a new job.

      I am able to save any other settings within the job configuration.

      I am yet to find a workaround for this.

        Attachments

          Issue Links

            Activity

            basil Basil Crow added a comment -

            I can reproduce this problem when all of the plugins listed in the "Environment" section are installed. I cannot reproduce this problem on a clean install of Jenkins.

            After some trial and error, I narrowed this down to Team Foundation Server 5.157.1. With this plugin installed, I could consistently reproduce this problem. After uninstalling Team Foundation Server, I could no longer reproduce this problem.

            I am reassigning this bug to the tfs-plugin component, as this does not appear to be an issue with the Workspace Cleanup plugin.

            basil Basil Crow added a comment -

            Duplicates JENKINS-64241. The problem is Team Foundation Server, which has been suspended due to licensing issues and is not available in new installations (see INFRA-2751). The recommendation is to disable or remove Team Foundation Server. For any additional questions, please use JENKINS-64241.


              People

              Assignee:
              redsolo redsolo
              Reporter:
              jackbartels Jack
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: