Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-65173

Active Choices Reactive Reference Parameter of type Formatted Hidden HTML is no longer hidden in Jenkins 2.277.1

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Minor
    • Resolution: Fixed
    • Component/s: active-choices-plugin
    • Labels:
      None
    • Environment:
      Jenkins: 2.277.1
      OS: Linux
      uno-choice:2.5.5
    • Similar Issues:

      Description

      We recently upgraded to Jenkins 2.277.1.  Some of our jobs have an "Active Choices Reactive Reference Parameter" that has Choice Type set to "Formatted Hidden HTML".

       

      Before the upgrade to 2.277.1, these parameters did not show up on the "Build with Parameters" page.

       

      After the upgrade to 2.277.1, these parameters do show up on the "Build with Parameters" page.

       

      We are running the Active Choice Parameter plugin version 2.5.5

        Attachments

          Activity

          kinow Bruno P. Kinoshita added a comment -

          Hi Don

          We tried to release a fix for the migration from HTML tables to divs that happened in a recent Jenkins release, but have found that the fix didn't cover all possible scenarios.

          Possibly this parameter type not being rendered is related to that issue. We have one pull request submitted by a contributor that appears to be related, but I'll need more time to properly reproduce each issue in each environment (normally need to do that in at least 2 versions of Jenkins, and old one and a recent LTS) and test the fix or write some code to fix it.

          Sorry for the inconvenience, feel free to ping this issue if it takes too long for being updated/resolved.

          Bruno

          ansig Anders Sigfridsson added a comment -

          Hi Bruno P. Kinoshita !

          We are seeing that hidden fields show up in the GUI too with Active Choices 2.5.5 and Jenkins 2.227.1.

          Appreciate that you picked up the issue already!

          /Anders

          kinow Bruno P. Kinoshita added a comment -

          Anders Sigfridsson I confirmed the latest version of Jenkins showed the hidden parameter label, due to JQuery not finding a parent table element (now they are DIVs).

          Included the fix while merging PR 46. I'm marking as resolved in 2.5.6, which should be available in a few minutes/hours. Could you, please, confirm that solves the issue?

          If not, feel free to re-open it.

          Thank you!

          kinow Bruno P. Kinoshita added a comment -

          In 2.5.6

          ansig Anders Sigfridsson added a comment -

          Bruno P. Kinoshita We tried 2.5.6 (with Jenkins 2.277.1) and it seems the issue is fixed.

          Thank you very much, really appreciate the quick fix!

           

          dmcgee2000 Don added a comment -

          Thanks Bruno P. Kinoshita.  I have installed the update and the problem seems to be resolved.

          kinow Bruno P. Kinoshita added a comment -

          Brilliant, thanks Anders Sigfridsson and Don !

           


            People

            Assignee:
            kinow Bruno P. Kinoshita
            Reporter:
            dmcgee2000 Don
            Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: