Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-65265

DRY plugin blocks create and edit of maven projects since 2.277.1

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Blocker
    • Resolution: Won't Fix
    • Component/s: dry-plugin
    • Environment:
      Jenkins version 2.277.1
      OS : Ubuntu 16.04
      Web browser : Chrome 89.0.4389.90
      List of Jenkins plugins : see plugins.txt attached
    • Similar Issues:

      Description

      Since the Jenkins v 2.277.1 we can not create a new maven project on Jenkins.
      And for existing projects we have the same issue

      In both cases the 'Save' and 'Apply' buttons do not work.

      We noticed some errors in the chrome console (ChromeConsole.PNG)

      If needed, the list of installed plugins can be found in the plugins.txt file.

      Thanks in advance for your help.

        Attachments

        1. ChromeConsole.PNG
          ChromeConsole.PNG
          115 kB
        2. ConfigureUI.PNG
          ConfigureUI.PNG
          89 kB
        3. plugins.txt
          4 kB

          Activity

          basil Basil Crow added a comment -

          Please follow the instructions in the Jenkins 2.277.1 upgrade guide and in the table to div layout migration guide to investigate the issue, including

          Disable any plugins that are no longer in use, particularly if those plugins are no longer distributed on the Jenkins update site

          such as analysis-core, checkstyle, and findbugs.

          If that does not bring you to a complete solution, then include the detailed information described here in this issue.

          oleg_nenashev Oleg Nenashev added a comment -

          In this case the Dry plugin is a root cause. It is explicitly deprecated, and I doubt we would fix tables-to-divs regressions there

          christopherz Christopher added a comment -

          Thank's for the advice.
          After removing the old deprecated plugins Jenkins is working fine again.

           

          markewaite Mark Waite added a comment -

          The DRY plugin is deprecated. Its functionality has been replaced by the warnings-ng plugin.


            People

            Assignee:
            Unassigned Unassigned
            Reporter:
            christopherz Christopher
            Votes:
            0 Vote for this issue
            Watchers:
            4 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: