Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-65426

message in pipeline: [withMaven] Infinite loop of job triggers

    XMLWordPrintable

Details

    • Bug
    • Status: Closed (View Workflow)
    • Minor
    • Resolution: Fixed
    • None

    Description

      Hi, I just started getting this error at the end of my pipelines:

      [withMaven] WARNING abort infinite build trigger loop. Please consider opening a Jira issue: Infinite loop of job triggers

      I see no other negative behavior, no failures, but this concerns me because:

      1. I've never seen it before,
      2. As far as I know I'm not using maven anywhere.

      Attachments

        Issue Links

          Activity

            ianw Ian Williams added a comment -

            bguerin, this is now marked as Fixed/Closed. The referenced duplicate issue ([JENKINS-62407|https://issues.jenkins.io/browse/JENKINS-62407)) is Open. Has this been fixed and if so, link to PR or which release it's fixed in pls?

            Otherwise, do I add same my comments to the Open one? The answer to "jobs doing `withMaven" in my case is no.

            ianw Ian Williams added a comment - bguerin , this is now marked as Fixed/Closed. The referenced duplicate issue ([ JENKINS-62407 |https://issues.jenkins.io/browse/JENKINS-62407)) is Open. Has this been fixed and if so, link to PR or which release it's fixed in pls? Otherwise, do I add same my comments to the Open one? The answer to "jobs doing `withMaven" in my case is no.
            aleitao Andre Leitao added a comment -

            I am getting this warning when rebuilding a previous run. In that case the build cause is the build itself.

            aleitao Andre Leitao added a comment - I am getting this warning when rebuilding a previous run. In that case the build cause is the build itself.
            bguerin Benoit added a comment -

            The `DownstreamPipelineTriggerRunListener` should not be executed in a non maven build, this is JENKINS-62407

            When solved, this side effect of "infinite loop" will go.

            So closing as duplicate of JENKINS-62407

            bguerin Benoit added a comment - The `DownstreamPipelineTriggerRunListener` should not be executed in a non maven build, this is JENKINS-62407 When solved, this side effect of "infinite loop" will go. So closing as duplicate of JENKINS-62407
            ianw Ian Williams added a comment - - edited

            Also got this error. Deliberately created an infinite loop job in response to [S/O question|hhttps://stackoverflow.com/a/68877975/598141], but withMaven is never invoked.

            Error seems to be coming from here: pipeline-maven-plugin/jenkins-plugin/src/main/java/org/jenkinsci/plugins/pipeline/maven/listeners/DownstreamPipelineTriggerRunListener.java

            ianw Ian Williams added a comment - - edited Also got this error. Deliberately created an infinite loop job in response to [S/O question|hhttps://stackoverflow.com/a/68877975/598141] , but withMaven is never invoked. Error seems to be coming from here: pipeline-maven-plugin/jenkins-plugin/src/main/java/org/jenkinsci/plugins/pipeline/maven/listeners/DownstreamPipelineTriggerRunListener.java

            People

              Unassigned Unassigned
              mcascone Max Cascone
              Votes:
              1 Vote for this issue
              Watchers:
              6 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: