Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-65637

Configuration failure when using synopsys-detect-7.0.0.jar

    XMLWordPrintable

    Details

    • Similar Issues:

      Description

      I used "Download via scripts or use DETECT_JAR" in global download strategy to integrate with blackduck instance and it was working fine using synopsys-detect-6.9.1 jar, but it keeps failing when  synopsys-detect-7.0.0 jar released on 13-May-2021 (today) as the plugin keeps forcing "blackduck.timeout" value in environment variable while it should be deprecated.

      it seems that 6.9.1 jar was bypassing deprecated properties but 7.0.0 isn't, which results in pipeline failure every time.

      error message: 

      blackduck.timeout: This property is now deprecated. Please use --detect.timeout in the future. It will cause failure in 7.0.0 and be removed in 8.0.0.

      resolution:
      1- either allow to download a certain version of  synopsys-detect jar
      or
      2-  remove Black Duck connection timeout property from mandatory plugin configuration

        Attachments

          Activity

          Hide
          karim_othman Karim added a comment -

          resolved by this issue

          Show
          karim_othman Karim added a comment - resolved by this issue
          Hide
          suvankardey123 Suvankar added a comment - - edited

          Whats the solutions? 

          Show
          suvankardey123 Suvankar added a comment - - edited Whats the solutions? 
          Hide
          karim_othman Karim added a comment -

          Suvankar.. I opened another issue on github synopsys-detect repo and they made a workaround by re-configuring their artifactory to return 6.9.1 version whenever it's asked to retrieve the latest... Please check this link

          Show
          karim_othman Karim added a comment - Suvankar .. I opened another issue on github synopsys-detect repo and they made a workaround by re-configuring their artifactory to return 6.9.1 version whenever it's asked to retrieve the latest... Please check this  link
          Hide
          sleepy Ronald Kamphuis added a comment -

          This solution doesn't work when using newer versions of Gradle (6.8 and up I believe). Suggestions on how to move forward with a setup like this?

          Show
          sleepy Ronald Kamphuis added a comment - This solution doesn't work when using newer versions of Gradle (6.8 and up I believe). Suggestions on how to move forward with a setup like this?

            People

            Assignee:
            rotte Richard Otte
            Reporter:
            karim_othman Karim
            Votes:
            1 Vote for this issue
            Watchers:
            4 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: