Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-6578

Backup plugin: Backing up to tar.gz fails

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Minor
    • Resolution: Duplicate
    • Component/s: backup-plugin
    • Labels:
      None
    • Environment:
      Windows Server 2008, Java 1.6.0_20 x86, Hudson 1.358
    • Similar Issues:

      Description

      When trying to back up to a tar.gz archive using the Backup plugin, an error occurs. The output of the backup operation looks like this:

      [ INFO] Backup started at [05/20/10 11:01:32]
      [ INFO] Setting hudson in shutdown mode to avoid files corruptions.
      [ INFO] Waiting all jobs end...
      [ INFO] Number of running jobs detected : 0
      [ INFO] All jobs finished.
      [ INFO] Full backup file name : C:\Program Files\Hudson\Backup\backup_20100520_1101.tar.gz
      [ERROR] org.codehaus.plexus.archiver.ArchiverException: Problem creating TAR: request to write '1372' bytes exceeds size in header of '91402' bytes
      org.jvnet.hudson.plugins.backup.BackupException: java.io.IOException: org.codehaus.plexus.archiver.ArchiverException: Problem creating TAR: request to write '1372' bytes exceeds size in header of '91402' bytes
      at org.jvnet.hudson.plugins.backup.utils.BackupEngine.doBackup(BackupEngine.java:115)
      at org.jvnet.hudson.plugins.backup.utils.BackupTask.run(BackupTask.java:125)
      at java.lang.Thread.run(Unknown Source)
      Caused by: java.io.IOException: org.codehaus.plexus.archiver.ArchiverException: Problem creating TAR: request to write '1372' bytes exceeds size in header of '91402' bytes
      at org.jvnet.hudson.plugins.backup.utils.BackupEngine.handleEnd(BackupEngine.java:104)
      at org.apache.commons.io.DirectoryWalker.walk(DirectoryWalker.java:336)
      at org.jvnet.hudson.plugins.backup.utils.BackupEngine.doBackup(BackupEngine.java:113)
      ... 2 more
      [ INFO] Cancel hudson shutdown mode
      [ INFO] Backup end at [05/20/10 11:01:38]
      [ INFO] [6.052s]

        Attachments

          Issue Links

            Activity

            aknuds1 Arve Knudsen added a comment -

            It looks like my issue is pretty much equivalent #5305.

            rseguy Romain Seguy added a comment -

            You're right, this is a duplicate of JENKINS-5305.

            rseguy Romain Seguy added a comment -

            Duplicates JENKINS-5305 --> Issue closed.


              People

              Assignee:
              rseguy Romain Seguy
              Reporter:
              aknuds1 Arve Knudsen
              Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: