Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-65928

Job trend page shows previous icons and use previous icon color for trend graph

    XMLWordPrintable

Details

    • Bug
    • Status: Closed (View Workflow)
    • Minor
    • Resolution: Fixed
    • core
    • None
    • Jenkins 2.289.1
    • 2.312, 2.341

    Description

      https://github.com/jenkinsci/jenkins/pull/5065 added new build status icons, but missed to also update the job trend page icons.

      Also the trend graph uses the colors from the previous icons and should be updated to use the newer icon colors.

      Attachments

        Activity

          cloos Christian Loos created issue -
          markewaite Mark Waite added a comment -

          Thanks for reporting the issue. I've confirmed that the issue is visible as described. Are you interested in submitting a pull request to correct the issue?

          markewaite Mark Waite added a comment - Thanks for reporting the issue. I've confirmed that the issue is visible as described. Are you interested in submitting a pull request to correct the issue?

          markewaite sadly I'm not familiar with Java, so I'm not able to fix this problem.

          cloos Christian Loos added a comment - markewaite sadly I'm not familiar with Java, so I'm not able to fix this problem.
          benebsiny Benny Cheng made changes -
          Field Original Value New Value
          Assignee Benny Cheng [ benebsiny ]
          markewaite Mark Waite made changes -
          Status Open [ 1 ] In Progress [ 3 ]
          markewaite Mark Waite made changes -
          Resolution Fixed [ 1 ]
          Status In Progress [ 3 ] Fixed but Unreleased [ 10203 ]
          markewaite Mark Waite made changes -
          Released As 2.312
          Status Fixed but Unreleased [ 10203 ] Closed [ 6 ]
          cloos Christian Loos made changes -
          Attachment jenkins_build_trend_graph.png [ 56313 ]

          benebsiny I reviewed your changes and it looks like you missed the second part of this issue.

          The trend graph still shows the wrong color.
          At least for successful builds the color should be changed from blue to green.
          Maybe also the colors for unstable and aborted builds can be adjusted to match the icon color.

          cloos Christian Loos added a comment - benebsiny I reviewed your changes and it looks like you missed the second part of this issue. The trend graph still shows the wrong color. At least for successful builds the color should be changed from blue to green. Maybe also the colors for unstable and aborted builds can be adjusted to match the icon color.
          cloos Christian Loos made changes -
          Resolution Fixed [ 1 ]
          Status Closed [ 6 ] Reopened [ 4 ]
          benebsiny Benny Cheng added a comment -

          cloos I missed the notification of your new message, so sorry. I mistook the trend graph for timeline graph, so I didn't fix it in the last pull request. Now I make a new pull request for the new color in the trend graph. Have a look at it. https://github.com/jenkinsci/jenkins/pull/5836

          benebsiny Benny Cheng added a comment - cloos I missed the notification of your new message, so sorry. I mistook the trend graph for timeline graph, so I didn't fix it in the last pull request. Now I make a new pull request for the new color in the trend graph. Have a look at it. https://github.com/jenkinsci/jenkins/pull/5836
          cchan Cathy made changes -
          Released As 2.312 2.312,2.319.1
          cchan Cathy made changes -
          Released As 2.312,2.319.1 2.312
          notmyfault Alexander Brandes made changes -
          Remote Link This issue links to "https://github.com/jenkinsci/jenkins/pull/5836 (Web Link)" [ 27503 ]
          markewaite Mark Waite made changes -
          Released As 2.312 2.312, 2.341
          Resolution Fixed [ 1 ]
          Status Reopened [ 4 ] Closed [ 6 ]

          People

            benebsiny Benny Cheng
            cloos Christian Loos
            Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: