Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-66074

After updating the sonar configuration to jenkins is not able to apply configuration setting

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Critical
    • Resolution: Cannot Reproduce
    • Component/s: sonar-plugin
    • Labels:
      None
    • Environment:
      Production
    • Similar Issues:

      Description

      I am going to integrate sonar Qube, after updating the sonar configuration to Jenkins is not able to apply the configuration setting. I have provided the details on Comment Section.

        Attachments

          Activity

          markewaite Mark Waite added a comment -

          Gourav I appreciate your request for help, but based on a first review of the list of plugins in your installation, you did not complete the steps that Ian Williams listed and that I listed again.

          As examples of evidence that you did not perform those steps:

          • Git plugin 3.7.0 is 4 years old. Current version is git plugin 4.7.2. Git plugin 3.7.0 is known to have issues with the tables to divs transition
          • Multiple SCMs plugin is deprecated and is known to have issues with tables to divs as documented in JENKINS-65726
          • Ruby runtime plugin is known to not work with Java 11 and will soon be removed
          • CVS plugin is likely unused as is mercurial plugin
          • analysis-core plugin is deprecated and no longer distributed
          • testnow-plugin is a privately built plugin that does not exist in the Jenkins update center
          • Security warnings have been issued for the following plugins in your list - analysis-core, ansible, aws-credentials, blueocean, build-pipeline-plugin, copyartifact, credentials-binding, cvs, dashboard-view, ec2, ghprb, git, git-client, github, github-branch-source, google-oauth-plugin, hipchat, htmlpublisher, jenkins-cloudformation-plugin, jira, jobConfigHistory, job-dsl, maven-plugin, mercurial, pipeline-aws, pipeline-model-definition, rebuild, resource-disposer, saml, sonar-quality-gates, ssh-agent, ssh-credentials, subversion, timestamper, workflow-cps, workflow-cps-global-lib
          gpokhra Gourav added a comment -

          Mark Waite Thanks you for the update. I will remove those plugin and try. 

          Please provide some time, if there any issue I will inform you.

          gpokhra Gourav added a comment -

          Mark Waite I have removed the plugin but after removing the plugin I have executed the one pipeline but it failed due to the below error : 

          java.lang.NullPointerException
          at java.util.TreeMap.putAll(TreeMap.java:313)
          at hudson.slaves.EnvironmentVariablesNodeProperty.buildEnvVars(EnvironmentVariablesNodeProperty.java:86)
          at hudson.model.Computer.buildEnvironment(Computer.java:1214)
          at hudson.model.Job.getEnvironment(Job.java:385)
          at hudson.model.Run.getEnvironment(Run.java:2442)
          at org.jenkinsci.plugins.workflow.job.WorkflowRun.getEnvironment(WorkflowRun.java:492)
          at org.jenkinsci.plugins.workflow.cps.CpsScmFlowDefinition.create(CpsScmFlowDefinition.java:112)
          at org.jenkinsci.plugins.workflow.cps.CpsScmFlowDefinition.create(CpsScmFlowDefinition.java:68)
          at org.jenkinsci.plugins.workflow.job.WorkflowRun.run(WorkflowRun.java:309)
          at hudson.model.ResourceController.execute(ResourceController.java:100)
          at hudson.model.Executor.run(Executor.java:433)
          Finished: FAILURE

          markewaite Mark Waite added a comment - - edited

          Either your description of the steps you've taken is missing many steps or you've not completed the steps provided by Ian Williams (listed) and me (listed again).

          When you said

          I have removed the plugin

          you did not mention which plugin was removed, nor did you mention if you've upgraded all the plugins with security warnings, nor did you describe what actions you took with the deprecated plugins. Others will not perform those steps for you. You are much better suited to explore plugin upgrades in your environment than anyone else is. You are much better suited to remove plugins in your environment than anyone else is.

          markewaite Mark Waite added a comment -

          Closing because insufficient information has been provided to duplicate the problem.


            People

            Assignee:
            sonarteam Sonar Team
            Reporter:
            gpokhra Gourav
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: