Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-66218

Plugin update screen ignores selection

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Cannot Reproduce
    • Component/s: core
    • Labels:
      None
    • Environment:
      Jenkins 2.289.2
      (JDK 11 LTS docker)
    • Similar Issues:

      Description

      Plugin manager - Updates tab. 

      I see list of plugins available to update. All checkboxes in "install" column are NOT checked on start.

      I see for example 3 rows, plugin A, B and C. I check plugin A and C, not B (i double checked this).

      Click "Download and install after restart".. 

      I see list of install progress and i see listed all 3 plugins A, C and B. - BUG!
      After restart A, C and B is installed. - BUG!

       

      Summary - install screen ignores checkbox selection and it seems it install always all listed plugins.

        Attachments

          Activity

          markewaite Mark Waite added a comment -

          If B is a dependency of A or of C, then I believe it will be downloaded whether or not it is selected.

          I just confirmed with Jenkins 2.289.2 that selective updates are honored on my system when there are no dependencies between the plugins. Updates were offered for the Git plugin and the Pipeline Graph View plugin. I selected the Git plugin and did not select the Pipeline Graph View plugin. When I pressed "Download now and install after restart", it downloaded only the Git plugin. The Pipeline Graph View plugin was not updated because I had not selected it and the Git plugin does not depend on the Pipeline Graph View plugin.

          Can you check the dependencies of the specific plugins (see https://plugins.jenkins.io/git/#dependencies for the list of dependencies of the git plugin as an example)?


            People

            Assignee:
            Unassigned Unassigned
            Reporter:
            bigboban Petr Leitner
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: