Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-66392

Token in Email Extension Plugin not working anymore after upgrade to Jenkins 2.289.3

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Minor
    • Resolution: Duplicate
    • Component/s: token-macro-plugin
    • Labels:
      None
    • Environment:
      Linux (CentOS 7)
      Jenkins 2.289.3
    • Similar Issues:
    • Released As:
      2.14

      Description

      Hi,

      We have a Jenkins job that uses the "Email Extension Plugin" in order to send emails with the content of a file as Default Content
      The job uses this functionality with this kind of token:
      ${FILE,path="file.txt"}

      Since upgrading Jenkins from version 2.263.3 to 2.289.3 in the emails Default Content we get ${FILE,path="file.txt"}
      instead it of the content of file.txt.
      After fallback to 2.263.3 the issue recovered again.

      Version of Email Extension Plugin used is 2.83

      Many thanks for your help!

      Brgrds,

      Steffen

       

        Attachments

          Issue Links

            Activity

            camusensei Namikaze Minato added a comment -

            Please note the Token Macro Plugin installed version is 2.13

            camusensei Namikaze Minato added a comment -

            Looks like a duplicate of JENKINS-66392 and JENKINS-65465

            basil Basil Crow added a comment -

            Duplicates JENKINS-64555. The solution is to update Token Macro to 2.14 or later. See the ASM update section of the Jenkins LTS 2.277.x upgrade guide.


              People

              Assignee:
              Unassigned Unassigned
              Reporter:
              swohlrab Steffen
              Votes:
              1 Vote for this issue
              Watchers:
              3 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: