Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-66853

Fix placement of AC parameter description on DIV-based Jenkins build forms

    XMLWordPrintable

Details

    • Bug
    • Status: Resolved (View Workflow)
    • Minor
    • Resolution: Fixed
    • active-choices-plugin
    • None
    • Jenkins v2.303.1 ; Active Choices v2.5.6

    Description

      The parameter description placement of Active Choice radio and checkbox parameters has changed. It now appears on the side of the AC selection options when rendered as radio or check boxes.

      It should appear after the parameter as it is shown for the AC1 parameter in the example (configuration file atatched)

      Attachments

        Activity

          Thanks a ton for the `config.xml` Ioannis. How about this fix? Making everything in each parameter section to be "stacked"?

           

          kinow Bruno P. Kinoshita added a comment - Thanks a ton for the `config.xml` Ioannis. How about this fix? Making everything in each parameter section to be "stacked"?  
          kinow Bruno P. Kinoshita added a comment - Fixed in this PR: https://github.com/jenkinsci/active-choices-plugin/pull/54

          kinow the layout is now consistent and it makes good sense. Thank you!

          ioannis Ioannis Moutsatsos added a comment - kinow  the layout is now consistent and it makes good sense. Thank you!

          Using Active Choices v2.6  (on Jenkins 2.319.2) I see a partial recovery of the desired layout and I can't reproduce the layout as shown for JENKINS-668553 above. The parameter LABEL and Control should be on the same line. Am I missing something?

          ioannis Ioannis Moutsatsos added a comment - Using Active Choices v2.6   (on Jenkins 2.319.2 ) I see a partial recovery of the desired layout and I can't reproduce the layout as shown for JENKINS-668553 above. The parameter LABEL and Control should be on the same line. Am I missing something?

          People

            kinow Bruno P. Kinoshita
            ioannis Ioannis Moutsatsos
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: