Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-67218

Unable to store any configuration with priority sorter plugin

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: prioritysorter-plugin
    • Labels:
    • Environment:
    • Similar Issues:
    • Released As:
      4.0.1 released Nov 27, 2021

      Description

      Whenever I am trying to save a configuration (job, plugin, etc.), jenkins tells me an oopsie.

      I attached example logs. In the end it always tells me something like:

      Caused: java.lang.IllegalArgumentException: Class [<A Bunch of classes here>] is specified in JSON, but no such class found in classLoader hudson.PluginManager$UberClassLoader.

      I tried upgrading/downgrading several plugins, but in the end it doesn't matter. As soon as I press a save/apply button the error appears and my changes do not take effect.

        Attachments

        1. advanced-build-queue.log
          11 kB
        2. jenkins_save_job.log
          13 kB
        3. plugins.txt
          3 kB
        4. README
          0.6 kB

          Issue Links

            Activity

            timja Tim Jacomb added a comment -

            Sounds like a tables to div bug.

            For the record acceptance tests are passing with this plugin:
            https://github.com/jenkinsci/acceptance-test-harness/blob/master/src/test/java/plugins/PrioritySorterPluginTest.java

            markewaite Mark Waite added a comment - - edited

            Thanks for the pointer to tables to divs Tim Jacomb. Per https://issues.jenkins.io/browse/JENKINS-65859, the plugin has not been updated to support configuration form modernization.

            However, I see that the 4.0.0 release includes JENKINS-64694 as a fix for tables to divs issues. May indicate that there are additional tables to divs issues that need to be handled in the plugin.

            Deeper analysis of the problem is reported in JENKINS-66938

            timja Tim Jacomb added a comment -

            Yeah looks like a duplicate of that issue

            markewaite Mark Waite added a comment -

            https://ci.jenkins.io/job/Plugins/job/priority-sorter-plugin/job/PR-88/ provides a prototype of the proposed fix. I'm not comfortable that the proposed fix will resolve the issue in all cases. I'd love to have others review it interactively and through the code.

            markewaite Mark Waite added a comment -

            Released 4.0.1 with the changes to fix this. Let me know if issues are detected with the fix.


              People

              Assignee:
              markewaite Mark Waite
              Reporter:
              vralfy Norman Specht
              Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: