Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-67413

Remove com.synopsys.arc.jenkins.plugins.rolestrategy.UserMacroExtension deprecated warnings

    XMLWordPrintable

Details

    Description

      Matrix Authorization 3.0 introduced changes Role-based Authorization does not support.

      Deprecated Role-based Authorization API warnings obfuscate significant future warnings.

      Removing these warnings is newbie-friendly by design.

      Attachments

        Issue Links

          Activity

            conrad_t_pino Conrad T. Pino created issue -
            conrad_t_pino Conrad T. Pino made changes -
            Field Original Value New Value
            Assignee Oleg Nenashev [ oleg_nenashev ] Conrad T. Pino [ conrad_t_pino ]
            conrad_t_pino Conrad T. Pino made changes -
            Link This issue relates to JENKINS-67393 [ JENKINS-67393 ]
            conrad_t_pino Conrad T. Pino made changes -
            Link This issue relates to JENKINS-67406 [ JENKINS-67406 ]
            conrad_t_pino Conrad T. Pino made changes -
            Remote Link This issue links to "PR 165 Remove com.synopsys.arc.jenkins.plugins.rolestrategy.UserMacroExtension deprecated warnings (Web Link)" [ 27310 ]
            conrad_t_pino Conrad T. Pino made changes -
            Link This issue relates to JENKINS-67425 [ JENKINS-67425 ]
            conrad_t_pino Conrad T. Pino made changes -
            Status Open [ 1 ] In Progress [ 3 ]
            conrad_t_pino Conrad T. Pino made changes -
            Status In Progress [ 3 ] In Review [ 10005 ]

            People

              conrad_t_pino Conrad T. Pino
              conrad_t_pino Conrad T. Pino
              Votes:
              1 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

                Created:
                Updated: