Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-67828

t:summary resolves icons against the wrong path (regression of the ionicon PR)

    XMLWordPrintable

Details

    • Bug
    • Status: Closed (View Workflow)
    • Minor
    • Resolution: Fixed
    • core
    • Jenkins version 2.335
    • 2.336 (Feb 22, 2022)

    Description

      This modification altered the behavior of the t:summary tag to resolve icons against the root path instead against the icon path.

      This references '<t:summary icon="icon-notepad">' in the cloudbees folder plugin, which should display a 48x48 notepad icon but results in

      I guess that can be mitigated by updating the plugins' references, but the introduced change is somewhat of breaking, because it removes the functionality to set icons via "icon-<icon>" at all, therefore it would be better to restore this functionality in core again.

      Mind taking a look janfaracik ?

      Attachments

        Issue Links

          Activity

            harryr7 Harry King added a comment -

            Also noticible with the Github plugin when using Orgnization Folders.  The image is prefixed with a slack resulting in https://jenkins.company.com/https://avatars.githubusercontent.com/u/1111111?v=4&s=16 

            harryr7 Harry King added a comment - Also noticible with the Github plugin when using Orgnization Folders.  The image is prefixed with a slack resulting in  https://jenkins.company.com/https://avatars.githubusercontent.com/u/1111111?v=4&s=16  

            That is tracked in https://issues.jenkins.io/browse/JENKINS-67823 and a different issue.

            notmyfault Alexander Brandes added a comment - That is tracked in https://issues.jenkins.io/browse/JENKINS-67823  and a different issue.
            harryr7 Harry King added a comment -

            Cheers Alex 

            harryr7 Harry King added a comment - Cheers Alex 

            People

              timja Tim Jacomb
              notmyfault Alexander Brandes
              Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: