Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-67907

Java 17 Phase 3: Require Java 17 or newer

    XMLWordPrintable

Details

    • Java 17 Phase 3: Require Java 17 or newer

    Description

      Update Jenkins to require Java 17 as the minimum development and runtime version instead of Java 11. Jenkins core components will be compiled with Java 17 and will require Java 17 or later at runtime. Jenkins plugins that depend on a Jenkins core that requires Java 17 must be compiled with Java 17.

      Attachments

        Issue Links

          Activity

            There are no comments yet on this issue.

            People

              Unassigned Unassigned
              basil Basil Crow
              Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

                Created:
                Updated: