Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-690

possible deadlock between SVN polling and scheduled builds

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: subversion-plugin
    • Labels:
      None
    • Environment:
      Platform: All, OS: Linux
    • Similar Issues:

      Description

      I have a Hudson v1.121 instance configured with three jobs. All three
      are freestyle projects using maven1 build commands and subversion for
      SCM. Two of the jobs poll the SCM every three minutes and also build
      periodically at 6am. The third job only builds periodically at
      4:30am.

      The problem is that one or more of the builds regularly hang in what
      seems to be some form of deadlock. Subsequent scheduled builds are
      held in "pending" status.

      Currently, the two jobs configured with polling are hung from when
      they were started at 6am on the 29th. There are also 3 pending
      builds, one for each of the three scheduled builds on the 30th.

      The consoles for the two hung jobs are empty and this message appeared
      in the Winstone stdout (or stderr?) output shortly after they were
      started:

      Jul 29, 2007 6:01:27 AM hudson.model.Build onStartBuilding
      INFO: Waiting for the polling of
      hudson.model.FreeStyleProject@4cc72243[NEWMAN] to complete
      Jul 29, 2007 6:01:27 AM hudson.model.Build onStartBuilding
      INFO: Waiting for the polling of
      hudson.model.FreeStyleProject@37b994de[NEWMAN-groovy] to complete

      I will attach a thread dump and the console output when I stop one of
      the jobs.

      Please let me know if I can provide any additional information to
      debug this issue.

      --Brad

        Attachments

          Activity

          bradfritz bradfritz added a comment -

          Forgot to mention this appears to be the same issue as
          described in this post:
          http://www.nabble.com/SVN-Connection-hanging-tf4159033.html

          bradfritz bradfritz added a comment -

          Created an attachment (id=73)
          thread dump captured while two jobs were hung

          bradfritz bradfritz added a comment -

          Created an attachment (id=74)
          console output after stopping one of the two stalled jobs

          bradfritz bradfritz added a comment -

          Looks like this might be fixed in 1.123 by the SCMTrigger.java r1.18 change:
          http://fisheye5.cenqua.com/changelog/hudson?cs=MAIN:kohsuke:20070730181220

          No hangs since upgrading. I'll give it a few more days and then close
          this issue.

          kohsuke Kohsuke Kawaguchi added a comment -

          Yes, I believe this issue should have been fixed in 1.123. Updated changelog.
          I'm marking this bug as fixed. Feel free to change it to VERIFIED or REOPENED,
          depending on how it goes.

          bradfritz bradfritz added a comment -

          After upgrading to 1.123 several scheduled runs that previously
          hung ran fine. Verifying closed. Thanks, Kohsuke!


            People

            Assignee:
            Unassigned Unassigned
            Reporter:
            bradfritz bradfritz
            Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: