Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-693

"java -jar hudson.war" dies if two different users attempt to run it

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: other
    • Labels:
      None
    • Environment:
      Platform: PC, OS: Linux
    • Similar Issues:

      Description

      java -jar hudson.war
      [Winstone 2007/07/31 12:46:53] - Beginning extraction from war file
      [Winstone 2007/07/31 12:46:53] - Error initializing web application: prefix []
      java.io.FileNotFoundException: /tmp/winstone/hudson.war/META-INF/MANIFEST.MF
      (No such file or directory)
      at java.io.FileOutputStream.open(Native Method)
      at java.io.FileOutputStream.<init>(FileOutputStream.java:179)
      at java.io.FileOutputStream.<init>(FileOutputStream.java:131)
      at winstone.HostConfiguration.getWebRoot(HostConfiguration.java:257)
      at winstone.HostConfiguration.<init>(HostConfiguration.java:73)
      at winstone.HostGroup.initHost(HostGroup.java:85)
      at winstone.HostGroup.<init>(HostGroup.java:45)
      at winstone.Launcher.<init>(Launcher.java:196)
      at winstone.Launcher.main(Launcher.java:391)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at
      sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at
      sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:597)
      at Main.main(Main.java:50)

      [Winstone 2007/07/31 12:46:53] - HTTP Listener started: port=8080
      [Winstone 2007/07/31 12:46:53] - AJP13 Listener started: port=8009
      [Winstone 2007/07/31 12:46:53] - Winstone Servlet Engine v0.9.9 running:
      controlPort=disabled
      [Winstone 2007/07/31 12:48:55] - Control thread shutdown successfully
      [Winstone 2007/07/31 12:48:55] - Winstone shutdown successfully

        Attachments

          Issue Links

            Activity

            slonopotamus slonopotamus added a comment -

            Sorry, local permission bug. Started hudson from another user before.

            Maybe it should use random temp directory.

            kohsuke Kohsuke Kawaguchi added a comment -

            Good idea.

            kohsuke Kohsuke Kawaguchi added a comment -

            This issue is being tracked at
            http://sourceforge.net/tracker/index.php?func=detail&aid=1765878&group_id=98922&atid=622500

            Updating the title to reflect the issue.

            kohsuke Kohsuke Kawaguchi added a comment -
                • Issue 746 has been marked as a duplicate of this issue. ***
            kohsuke Kohsuke Kawaguchi added a comment -

            This fix is now integrated in Hudson 1.181.


              People

              Assignee:
              Unassigned Unassigned
              Reporter:
              slonopotamus slonopotamus
              Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: