Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-7075

Enhance buildEnvironments so that global- and build-wrapper env variables are made available to post-build actions

    XMLWordPrintable

    Details

    • Type: Improvement
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Duplicate
    • Component/s: core
    • Labels:
      None
    • Similar Issues:

      Description

      This is required so that email recipient lists can refer to environment variables (see JENKINS-6394). There are probably other use cases as well.

        Attachments

          Issue Links

            Activity

            mindless Alan Harder added a comment -

            added "and build-wrapper" in issue summary, to include problem from the issues marked as duplicate of this one.. for example, variable from versionnumber plugin not available to publishers.


              People

              Assignee:
              Unassigned Unassigned
              Reporter:
              mwebber Matthew Webber
              Votes:
              5 Vote for this issue
              Watchers:
              5 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: