Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-7096

User is created even if invalid or missing information is typed

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Minor
    • Resolution: Fixed
    • Component/s: core
    • Labels:
      None
    • Similar Issues:

      Description

      When trying to sign up, if user does not type in a password and/or email address and error message will display stating that password is missing or email address is invalid. But user will still be created.

        Attachments

          Issue Links

            Activity

            mdonohue mdonohue added a comment -

            Looks like JENKINS-3590 A critical part of any bug report is missing: What version of Hudson are you using?

            alfville alfville added a comment -

            I am using version 1.367.

            alfville alfville added a comment -

            Updated issue by replacing "sign in" with "sign up", which is the correct one.

            evernat evernat added a comment - - edited

            It is similar but it is NOT the same issue as JENKINS-3590, because 3590 was about the login page and this one is about the sign up page.
            This issue is easy to reproduce in Jenkins v1.420: using the built-in user management, the user is created in-memory after submitting the sign up page without a password or without a valid e-mail address. Jenkins needs to be restarted to forget the incomplete user.

            Except if there is a good reason, I agree that the user should not be created in-memory if submitting the sign up page displays an error such as missing password or invalid e-mail address.

            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: Vojtech Juranek
            Path:
            changelog.html
            core/src/main/java/hudson/security/HudsonPrivateSecurityRealm.java
            http://jenkins-ci.org/commit/jenkins/cc571a3a2cef5a5bb68384088158e9977e34db42
            Log:
            Merge branch 'JENKINS-7096' of https://github.com/mc1arke/jenkins

            Conflicts:
            changelog.html

            mc1arke Michael Clarke added a comment -

            Fixed in Version 1.449. Jenkins no longer creates a user unless they pass all the validation properly

            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: Michael Clarke
            Path:
            changelog.html
            core/src/main/java/hudson/security/HudsonPrivateSecurityRealm.java
            http://jenkins-ci.org/commit/jenkins/255a3e6dd67d91e74541293bf7d3ea696b01b6c1
            Log:
            JENKINS-7096 - Stop users being created in memory if registration fails


              People

              Assignee:
              mc1arke Michael Clarke
              Reporter:
              alfville alfville
              Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: