Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-8280

AD 1.17 doesn't work

    XMLWordPrintable

Details

    • Bug
    • Status: Closed (View Workflow)
    • Blocker
    • Resolution: Duplicate
    • None
    • version: hudson 1.387
      os: windows xp

    Description

      After I upgrade AD plugin from 1.16 to 1.17,I fail to login again!!

      Attachments

        Issue Links

          Activity

            ljnelson Laird Nelson added a comment -

            Despite this bug's lack of detail, I can confirm it. I recently upgraded Hudson from 1.388 to 1.394 and installed the Active Directory plugin v1.17. In the prior installation (1.16), all I had to do was specify my domain, and everything simply worked like magic. In the new one, the Test button worked with only a domain specified, but actually logging in was impossible.

            This is in a Windows environment.

            ljnelson Laird Nelson added a comment - Despite this bug's lack of detail, I can confirm it. I recently upgraded Hudson from 1.388 to 1.394 and installed the Active Directory plugin v1.17. In the prior installation (1.16), all I had to do was specify my domain, and everything simply worked like magic. In the new one, the Test button worked with only a domain specified, but actually logging in was impossible. This is in a Windows environment.
            tkrah Torsten Krah added a comment -

            Guess this is because 1.17 does all via ldaps - not ldap anymore.
            Got an AD too but no certificate management and no ssl support on the server side (which i do not want to change).

            Even using:

            hudson.plugins.active_directory.ActiveDirectorySecurityRealm.domainControllers" with the value of the format "host:port,host:port,...". The port should be normally 3269 (for global catalog over SSL), 636 (LDAP over SSL), 3268 (for global catalog), or 389 (LDAP.)

            does not work - because ssl is forced, but there is no one on the server side which does speak ssl.

            Please make an additional option to switch between non-ssl and ssl - like:

            hudson.plugins.active_directory.ssl=false

            thx.

            tkrah Torsten Krah added a comment - Guess this is because 1.17 does all via ldaps - not ldap anymore. Got an AD too but no certificate management and no ssl support on the server side (which i do not want to change). Even using: hudson.plugins.active_directory.ActiveDirectorySecurityRealm.domainControllers" with the value of the format "host:port,host:port,...". The port should be normally 3269 (for global catalog over SSL), 636 (LDAP over SSL), 3268 (for global catalog), or 389 (LDAP.) does not work - because ssl is forced, but there is no one on the server side which does speak ssl. Please make an additional option to switch between non-ssl and ssl - like: hudson.plugins.active_directory.ssl=false thx.
            crazycanuck41 Bob Reid added a comment -

            This is a duplicate of JENKINS-8132. There is more activity on that issue so I recommend voting/watching that issue.

            crazycanuck41 Bob Reid added a comment - This is a duplicate of JENKINS-8132 . There is more activity on that issue so I recommend voting/watching that issue.

            Marking as duplicate as suggested by Bob Reid.

            kohsuke Kohsuke Kawaguchi added a comment - Marking as duplicate as suggested by Bob Reid.

            People

              Unassigned Unassigned
              lynn_lin lynn_lin
              Votes:
              4 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: