Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-8459

Add way of passing arbitary options to the equinox launchers

    XMLWordPrintable

    Details

    • Similar Issues:

      Description

      When I use the buckminster plugin, it generates a command that looks like this (file paths edited for brevity):

      java -Dbuckminster.output.root=/workspace/buckminster.output -Dbuckminster.temp.root=/workspace/buckminster.temp -Xmx256m -jar /buckminster/plugins/org.eclipse.equinox.launcher_1.1.1.R36x_v20101122_1400.jar -application org.eclipse.buckminster.cmdline.headless -data /workspace --loglevel debug -S /workspace/commands.txt
      

      I need one slight change to that. I need the text

        -keyring ~/.gda/.keyring
      

      inserted AFTER the equinox.launcher.jar, and BEFORE the -application, so that it is an argument to the launcher. So the command should look like:

      ... -jar /buckminster/plugins/org.eclipse.equinox.launcher_1.1.1.R36x_v20101122_1400.jar -keyring ~/.gda/.keyring -application  ...
      

      The problem is, there is no way to do this. There are 2 places to set Buckminsters options, but neither is suitable:

      • In the main Hudson configuration settings, Buckminster supports an "Additonal Startup Parameters" setting, but this is passed to "java", not to the equinox launcher.
      • In the individual job configuration settings, Buckminster supports a "JVM Arguments" setting (under advanced options), but this is passed to the org.eclipse.buckminster.cmdline.headless application, not to its launcher.

      Would it be possible to add an extra configuration option to the job, as an Advanced option, where one could specify additional launcher arguments (eg -keyring)?

      Wihtout this, I can't use the Buckminster plugin, and will need to code the backminster commands directly in a shell script.

        Attachments

          Activity

          jutzig jutzig added a comment -

          Would it be possible to add an extra configuration option to the job, as an Advanced option, where one could specify additional launcher arguments (eg -keyring)?

          I see your problem. Yes, adding this option is quite possible and I will do so within the next days.
          However I did have issues with my commit access lately (due to the changes in the hudson infrastructure and on dev.java.net) so I am unsure if I can commit changes at the moment and how long the release process will take.
          If this is urgent I could provide either a patch or a custom build of the plugin

          mwebber Matthew Webber added a comment -

          If this is urgent I could provide either a patch or a custom build of the plugin

          Naturally I'd prefer to use the plugin, but I have a workaround for the moment (I hard-coded the buckminster command). So, please don't go to extra trouble, I'll pick up the fix as soon as you release it via the normal cycle.

          Thanks for the quick response.

          jutzig jutzig added a comment -

          Fix released to Trunk rev. 38144.
          Triggered release of 1.0.8.


            People

            Assignee:
            jutzig jutzig
            Reporter:
            mwebber Matthew Webber
            Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: