Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-8568

the cobertura plugin can't show the right color for the CoverageResult.all the color show the green,in fact the coverage rate lower than 100%

    XMLWordPrintable

Details

    • Bug
    • Status: Resolved (View Workflow)
    • Critical
    • Resolution: Fixed
    • cobertura-plugin
    • None
    • windows xp; tomcat 7.0;hudson 1.393

    Description

      the cobertura plugin can't show the right color for the CoverageResult.all the color show the green,in fact the coverage rate lower than 100%.
      the cobertura coverage result calculation is right, but can't show the right color. i have try to setup the new enviroment, the grath still show the green.

      Attachments

        1. CoberturaAllGreen.PNG
          16 kB
          Mike Vitale
        2. CoberturaRedGreen.PNG
          13 kB
          Mike Vitale

        Activity

          mikevitale42 Mike Vitale added a comment -

          Server is Windows XP, running Jenkins 1.415 as a Windows Service from the Native Installer. Cobertura Plugin is v1.2. Static Code Analysis Plugin is v1.22.

          mikevitale42 Mike Vitale added a comment - Server is Windows XP, running Jenkins 1.415 as a Windows Service from the Native Installer. Cobertura Plugin is v1.2. Static Code Analysis Plugin is v1.22.
          mikevitale42 Mike Vitale added a comment -

          This second screenshot is the results when viewed in Firefox v3.6.13. The first screenshot (and the one that only shows all-green results) is in MSIE 8.0.6001.18702CO.

          Apparently this issue is only reproducible in MSIE.

          mikevitale42 Mike Vitale added a comment - This second screenshot is the results when viewed in Firefox v3.6.13. The first screenshot (and the one that only shows all-green results) is in MSIE 8.0.6001.18702CO. Apparently this issue is only reproducible in MSIE.
          mikevitale42 Mike Vitale added a comment -

          Further information: The colors are correct (both red and green) under the same version of MSIE on mycompany's Hudson server (1.327) using version 0.8.9 of the Cobertura plugin.

          mikevitale42 Mike Vitale added a comment - Further information: The colors are correct (both red and green) under the same version of MSIE on mycompany's Hudson server (1.327) using version 0.8.9 of the Cobertura plugin.
          mikevitale42 Mike Vitale added a comment -

          Further information: The red/green colors display correctly in MSIE8 when document is rendered in IE8 Standards Mode. When in Quirks Mode, it's all-green.

          mikevitale42 Mike Vitale added a comment - Further information: The red/green colors display correctly in MSIE8 when document is rendered in IE8 Standards Mode. When in Quirks Mode, it's all-green.

          Code changed in jenkins
          User: ssogabe
          Path:
          src/main/webapp/css/style.css
          http://jenkins-ci.org/commit/cobertura-plugin/c8024ac65e9e1f674869515869aa8686dcaf412e
          Log:
          [FIXED JENKINS-8568] show greenbar collectly in IE Quirks Mode

          scm_issue_link SCM/JIRA link daemon added a comment - Code changed in jenkins User: ssogabe Path: src/main/webapp/css/style.css http://jenkins-ci.org/commit/cobertura-plugin/c8024ac65e9e1f674869515869aa8686dcaf412e Log: [FIXED JENKINS-8568] show greenbar collectly in IE Quirks Mode

          People

            sogabe sogabe
            lg2698 lg2698
            Votes:
            1 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: