Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-8636

TestLink Plugin FATAL: Error creating test project

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Not A Defect
    • Component/s: testlink-plugin
    • Labels:
      None
    • Environment:
      Hudson running on Linux (Ubuntu 10.04 LTS) with TestLink (1.9 RC1) on the same box.
      Jenkins ver. 1.499, TestLink 1.9.5 and Testlink plugin 3.1.8
    • Similar Issues:

      Description

      I was hoping you could help me out with the below error I am receiving when attempting to use the testlink plugin for Hudson.

      Here is a screen shot (also attached) of what my hudson project's configuration looks like for invoking the Testlink plugin: http://scrnsht.com/kypwgs

      I have a custom field in TestLink with a label of "Automated Test Class" containing the full package name of my test class i.e. com.company.sourcing.gression.splittingTestSuite

      Retrieving TestLink details about Test Project, Test Plan and Build.
      FATAL: Error creating test project: Failed to parse server's response: The processing instruction target matching "[xX][mM][lL]" is not allowed.

      br.eti.kinoshita.testlinkjavaapi.TestLinkAPIException: Error creating test project: Failed to parse server's response: The processing instruction target matching "[xX][mM][lL]" is not allowed.

      at br.eti.kinoshita.testlinkjavaapi.TestProjectService.getTestProjectByName(TestProjectService.java:134)

      at br.eti.kinoshita.testlinkjavaapi.TestLinkAPI.getTestProjectByName(TestLinkAPI.java:347)

      at hudson.plugins.testlink.finder.AutomatedTestCasesFinder.retrieveTestLinkData(AutomatedTestCasesFinder.java:157)

      at hudson.plugins.testlink.finder.AutomatedTestCasesFinder.findAutomatedTestCases(AutomatedTestCasesFinder.java:127)

      at hudson.plugins.testlink.TestLinkBuilder.perform(TestLinkBuilder.java:447)

      at hudson.plugins.m2extrasteps.M2ExtraStepsWrapper.executeBuildSteps(M2ExtraStepsWrapper.java:166)

      at hudson.plugins.m2extrasteps.M2ExtraStepsWrapper.setUp(M2ExtraStepsWrapper.java:126)

      at hudson.maven.MavenModuleSetBuild$RunnerImpl.doRun(MavenModuleSetBuild.java:521)

      at hudson.model.AbstractBuild$AbstractRunner.run(AbstractBuild.java:420)
      at hudson.model.Run.run(Run.java:1362)

      at hudson.maven.MavenModuleSetBuild.run(MavenModuleSetBuild.java:405)
      at hudson.model.ResourceController.execute(ResourceController.java:88)

      at hudson.model.Executor.run(Executor.java:145)
      Caused by: org.apache.xmlrpc.client.XmlRpcClientException: Failed to parse server's response: The processing instruction target matching "[xX][mM][lL]" is not allowed.

      at org.apache.xmlrpc.client.XmlRpcStreamTransport.readResponse(XmlRpcStreamTransport.java:188)

      at org.apache.xmlrpc.client.XmlRpcStreamTransport.sendRequest(XmlRpcStreamTransport.java:156)

      at org.apache.xmlrpc.client.XmlRpcHttpTransport.sendRequest(XmlRpcHttpTransport.java:143)

      at org.apache.xmlrpc.client.XmlRpcSunHttpTransport.sendRequest(XmlRpcSunHttpTransport.java:69)

      at org.apache.xmlrpc.client.XmlRpcClientWorker.execute(XmlRpcClientWorker.java:56)

      at org.apache.xmlrpc.client.XmlRpcClient.execute(XmlRpcClient.java:167)
      at org.apache.xmlrpc.client.XmlRpcClient.execute(XmlRpcClient.java:158)

      at org.apache.xmlrpc.client.XmlRpcClient.execute(XmlRpcClient.java:147)
      at br.eti.kinoshita.testlinkjavaapi.BaseService.executeXmlRpcCall(BaseService.java:124)

      at br.eti.kinoshita.testlinkjavaapi.TestProjectService.getTestProjectByName(TestProjectService.java:126)

      ... 12 more
      Caused by: org.xml.sax.SAXParseException: The processing instruction target matching "[xX][mM][lL]" is not allowed.

      at com.sun.org.apache.xerces.internal.parsers.AbstractSAXParser.parse(AbstractSAXParser.java:1231)

      at com.sun.org.apache.xerces.internal.jaxp.SAXParserImpl$JAXPSAXParser.parse(SAXParserImpl.java:522)

      at org.apache.xmlrpc.client.XmlRpcStreamTransport.readResponse(XmlRpcStreamTransport.java:186)

      ... 21 more

      ERROR: Error creating test project: Failed to parse server's response: The processing instruction target matching "[xX][mM][lL]" is not allowed.

      Thank you so much, I do hope you can help out.

        Attachments

          Activity

          kinow Bruno P. Kinoshita added a comment -

          There was similar error, but the message was different. If you find similar issue again, please attach as much information as possible. In case you're having problems with the data exchanged between TestLink and Jenkins, in order to help, I might need you to sniff the connection between Jenkins and TL (using QDPF, Wireshark, or some other tool of your preference). I'm cutting a new release anyway, but feel free to add any comment here or let me know if you find any blocker.

          msacchetti Michele Sacchetti added a comment -

          Hi There

          I'm having the same error with testlink 1.9.6, jenkins 1.512 and plugin 3.5

          doing a post to the API call with

          <?xml version="1.0" encoding="UTF-8"?><methodCall xmlns:ex="http://ws.apache.org/xmlrpc/namespaces/extensions"><methodName>tl.checkDevKey</methodName><params><param><value><struct><member><name>devKey</name><value>041053c00fc00b7f3f895959bd0d6a09</value></member></struct></value></param></params></methodCall>

          I get a response as

          <?xml version="1.0"?>
          <methodResponse>
            <params>
              <param>
                <value>
                  <boolean>1</boolean>
                </value>
              </param>
            </params>
          </methodResponse>

          so it seem there is a newline before the xml header (code formatting is removing it, but it's there ).
          doing a capture on the testlink server it seems it's getting the same response before failing.

          is there a way to have this newline removed? is this editable in any testlink php file?

          tniemi Teemu Niemi added a comment -

          Hello,

          check Testlink custom_config.inc.php/config_db.inc.php files for the extra new lines.

          Our problem was caused by the extra line in end of the config_db.inc.php.

          Removing \n after the ?> in config_db.inc.php resolved the issue.

          Also it would be good to check that these configuration files starts and ends with proper php tags.

          kinow Bruno P. Kinoshita added a comment -

          Closing since it's a problem with the TestLink installation, and not with the plug-in (nor we can hack a fix in the plug-in code, sorry)

          edsherwin Ed Sherwin Nonog added a comment -

          Hi Sir Bruno P. Kinoshita

          I have the same problem in connecting testlink with jenkins.

          The error was: Error verifying developer key: Failed to read server's response: Connection timed out.

          Thank You,
          Ed

          FATAL: Error verifying developer key: Failed to read server's response: Connection timed out
          br.eti.kinoshita.testlinkjavaapi.util.TestLinkAPIException: Error verifying developer key: Failed to read server's response: Connection timed out
          at br.eti.kinoshita.testlinkjavaapi.MiscService.checkDevKey(MiscService.java:63)
          at br.eti.kinoshita.testlinkjavaapi.TestLinkAPI.<init>(TestLinkAPI.java:144)
          at hudson.plugins.testlink.TestLinkBuilder.getTestLinkSite(TestLinkBuilder.java:307)
          at hudson.plugins.testlink.TestLinkBuilder.perform(TestLinkBuilder.java:186)
          at hudson.tasks.BuildStepMonitor$1.perform(BuildStepMonitor.java:20)
          at hudson.model.AbstractBuild$AbstractBuildExecution.perform(AbstractBuild.java:782)
          at hudson.model.Build$BuildExecution.build(Build.java:205)
          at hudson.model.Build$BuildExecution.doRun(Build.java:162)
          at hudson.model.AbstractBuild$AbstractBuildExecution.run(AbstractBuild.java:534)
          at hudson.model.Run.execute(Run.java:1738)
          at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:43)
          at hudson.model.ResourceController.execute(ResourceController.java:98)
          at hudson.model.Executor.run(Executor.java:410)
          Caused by: org.apache.xmlrpc.XmlRpcException: Failed to read server's response: Connection timed out
          at org.apache.xmlrpc.client.XmlRpcStreamTransport.sendRequest(XmlRpcStreamTransport.java:161)
          at org.apache.xmlrpc.client.XmlRpcHttpTransport.sendRequest(XmlRpcHttpTransport.java:143)
          at org.apache.xmlrpc.client.XmlRpcSunHttpTransport.sendRequest(XmlRpcSunHttpTransport.java:69)
          at org.apache.xmlrpc.client.XmlRpcClientWorker.execute(XmlRpcClientWorker.java:56)
          at org.apache.xmlrpc.client.XmlRpcClient.execute(XmlRpcClient.java:167)
          at org.apache.xmlrpc.client.XmlRpcClient.execute(XmlRpcClient.java:158)
          at org.apache.xmlrpc.client.XmlRpcClient.execute(XmlRpcClient.java:147)
          at br.eti.kinoshita.testlinkjavaapi.BaseService.executeXmlRpcCall(BaseService.java:90)
          at br.eti.kinoshita.testlinkjavaapi.MiscService.checkDevKey(MiscService.java:60)
          ... 12 more
          Caused by: java.net.ConnectException: Connection timed out
          at java.net.PlainSocketImpl.socketConnect(Native Method)
          at java.net.AbstractPlainSocketImpl.doConnect(AbstractPlainSocketImpl.java:350)
          at java.net.AbstractPlainSocketImpl.connectToAddress(AbstractPlainSocketImpl.java:206)
          at java.net.AbstractPlainSocketImpl.connect(AbstractPlainSocketImpl.java:188)
          at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:392)
          at java.net.Socket.connect(Socket.java:589)
          at java.net.Socket.connect(Socket.java:538)
          at sun.net.NetworkClient.doConnect(NetworkClient.java:180)
          at sun.net.www.http.HttpClient.openServer(HttpClient.java:432)
          at sun.net.www.http.HttpClient.openServer(HttpClient.java:527)
          at sun.net.www.http.HttpClient.<init>(HttpClient.java:211)
          at sun.net.www.http.HttpClient.New(HttpClient.java:308)
          at sun.net.www.http.HttpClient.New(HttpClient.java:326)
          at sun.net.www.protocol.http.HttpURLConnection.getNewHttpClient(HttpURLConnection.java:1169)
          at sun.net.www.protocol.http.HttpURLConnection.plainConnect0(HttpURLConnection.java:1105)
          at sun.net.www.protocol.http.HttpURLConnection.plainConnect(HttpURLConnection.java:999)
          at sun.net.www.protocol.http.HttpURLConnection.connect(HttpURLConnection.java:933)
          at sun.net.www.protocol.http.HttpURLConnection.getOutputStream0(HttpURLConnection.java:1283)
          at sun.net.www.protocol.http.HttpURLConnection.getOutputStream(HttpURLConnection.java:1258)
          at org.apache.xmlrpc.client.XmlRpcSunHttpTransport.writeRequest(XmlRpcSunHttpTransport.java:104)
          at org.apache.xmlrpc.client.XmlRpcStreamTransport.sendRequest(XmlRpcStreamTransport.java:151)
          ... 20 more
          ERROR: Error communicating with TestLink. Check your TestLink configuration.
          [BFA] Scanning build for known causes...
          [BFA] No failure causes found
          [BFA] Done. 0s
          Notifying upstream projects of job completion
          Finished: FAILURE


            People

            Assignee:
            kinow Bruno P. Kinoshita
            Reporter:
            silvercolt silvercolt
            Votes:
            1 Vote for this issue
            Watchers:
            8 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: