Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-9178

cppcheck plugin missing files if used by a matrix project

    XMLWordPrintable

Details

    • Bug
    • Status: Closed (View Workflow)
    • Minor
    • Resolution: Fixed
    • cppcheck-plugin
    • None
    • debian linux lenny
      jenkins 1.400
      cppcheck 1.47

    Description

      Following message is displayed in the log file:
      ....
      [Cppcheck] Starting the cppcheck analysis.
      [Cppcheck] Processing 1 files with the pattern '**/*cppcheck.xml'.
      [Cppcheck] [WARNING] - The source file 'file:/hudson/jenkins/jenkins/jobs/xxxx/workspace/ARCH/i386/DEBUG/false/binsrc/yyyyyy.cpp' doesn't exist on the slave. The ability to display its source code has been removed.

      The result is, that the file has no link in the cppcheck results.

      The cause is, cppcheck reports the file with an relatve path, binsrc/xxxxx.cpp, but the plugin search the file in the wrong path.
      The local module directory should be added to the path if it exists (we use svn repository), it should look like
      file:/hudson/jenkins/jenkins/jobs/xxxx/workspace/ARCH/i386/DEBUG/false/xxxx/binsrc/yyyyyy.cpp.
      While xxxx is the local module directory, defined as optional scm subversion property.

      Attachments

        Activity

          mixalturek Michal Turek added a comment -

          Closing.

          mixalturek Michal Turek added a comment - Closing.

          Fix available in 1.0.1

          gbois Gregory Boissinot added a comment - Fix available in 1.0.1

          Code changed in jenkins
          User: Gregory Boissinot
          Path:
          src/main/java/org/jenkinsci/plugins/cppcheck/CppcheckPublisher.java
          http://jenkins-ci.org/commit/cppcheck-plugin/109634c9e4bca4aff2dd9f3970ece005e42bbb0c
          Log:
          Fix JENKINS-9178

          scm_issue_link SCM/JIRA link daemon added a comment - Code changed in jenkins User: Gregory Boissinot Path: src/main/java/org/jenkinsci/plugins/cppcheck/CppcheckPublisher.java http://jenkins-ci.org/commit/cppcheck-plugin/109634c9e4bca4aff2dd9f3970ece005e42bbb0c Log: Fix JENKINS-9178

          People

            gbois Gregory Boissinot
            wohauser wohauser
            Votes:
            1 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: