Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-1023

Maven Site site:deploy fails because of SCP command

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Duplicate
    • Component/s: maven-plugin
    • Labels:
      None
    • Environment:
      Platform: All, OS: Linux
    • Similar Issues:

      Description

      We're using Hudson 1.149 and the Hudson Maven2 Project support.

      When we execute the maven command "mvn clean deploy site site:deploy" from the
      command line, everything works fine.

      However, if we do the same thing in Hudson then the SCP fails when deploying the
      site. Here is the Hudson/Maven output from the console.

      [INFO] [site:deploy]
      [HUDSON] Archiving
      /home/administrator/.hudson/jobs/TAUtilities_1.2_DEV/workspace/pom.xml
      [INFO] ------------------------------------------------------------------------
      [ERROR] BUILD ERROR
      [INFO] ------------------------------------------------------------------------
      [INFO] Unsupported protocol: 'scp'

      Embedded error: Cannot find wagon which supports the requested protocol: scp
      Component composition failed. No field of type: 'interface
      org.apache.maven.wagon.providers.ssh.knownhost.KnownHostsProvider' exists in
      class 'org.apache.maven.wagon.providers.ssh.jsch.ScpWagon'. Component: role:
      'org.apache.maven.wagon.Wagon', implementation:
      'org.apache.maven.wagon.providers.ssh.jsch.ScpWagon', role hint: 'scp'
      [INFO] ------------------------------------------------------------------------
      [INFO] For more information, run Maven with the -e switch
      [INFO] ------------------------------------------------------------------------
      [INFO] Total time: 2 minutes 57 seconds
      [INFO] Finished at: Tue Nov 20 09:00:29 MST 2007
      [INFO] Final Memory: 50M/93M
      [INFO] ------------------------------------------------------------------------
      finished: FAILURE

        Attachments

          Issue Links

            Activity

            kohsuke Kohsuke Kawaguchi added a comment -

            Fixed in 1.159. This must be because Hudson is somehow bundling all wagon providers.

            brentryan brentryan added a comment -

            I tested version 1.159 by upgrading my instance of Hudson and I still got the error.

            Here are the steps I did to upgrade Hudson so let me know if I did something wrong:
            1. stop Tomcat
            2. Remove webapps/hudson and webapps/hudson.war
            3. copy new hudson.war to webapps/
            4. Start Tomcat
            5. Test maven goals "clean deploy site site:deploy" using hudson.

            This produces the following error:

            [ERROR] BUILD ERROR

            [INFO] ------------------------------------------------------------------------

            [INFO] Unsupported protocol: 'scp'

            Embedded error: Cannot find wagon which supports the requested protocol: scp

            Component composition failed. No field of type: 'interface
            org.apache.maven.wagon.providers.ssh.knownhost.KnownHostsProvider' exists in
            class 'org.apache.maven.wagon.providers.ssh.jsch.ScpWagon'. Component: role:
            'org.apache.maven.wagon.Wagon', implementation:
            'org.apache.maven.wagon.providers.ssh.jsch.ScpWagon', role hint: 'scp'

            [INFO] ------------------------------------------------------------------------

            [INFO] For more information, run Maven with the -e switch

            [INFO] ------------------------------------------------------------------------

            [INFO] Total time: 4 minutes 45 seconds

            [INFO] Finished at: Mon Nov 26 06:00:36 MST 2007

            [INFO] Final Memory: 47M/126M

            [INFO] ------------------------------------------------------------------------

            Sending e-mails to: *****

            finished: FAILURE

            Hudson ver. 1.159

            kohsuke Kohsuke Kawaguchi added a comment -

            This is the same problem as reported in 1102. Fixed in 1.162.

                • This issue has been marked as a duplicate of 1102 ***

              People

              Assignee:
              Unassigned Unassigned
              Reporter:
              brentryan brentryan
              Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: