Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-1102

maven build error w/parent pom

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Critical
    • Resolution: Fixed
    • Component/s: maven-plugin
    • Labels:
      None
    • Environment:
      Platform: All, OS: All
    • Similar Issues:

      Description

      We have an organizational pom that every project inherits from. When we build
      this project from the command line directly, using mvn clean deploy site, it
      builds fine. However, when we schedule this to build via Hudson's Job interface,
      we get the following console output below. The parent pom is installed in
      ~/.m2/repository and settings.xml contains the repository locations. When we use
      hudson 1.119 (with maven 2.0.8), it all works fine. We're currently at maven
      2.0.8 and hudson 1.161.

      started
      Updating http://subversion.../trunk
      At revision 230
      no change for http://subversion.../trunk since the previous build
      Parsing POMs
      ERROR: Failed to parse POM
      org.apache.maven.project.ProjectBuildingException: Cannot find parent:
      com.polk.community:base-jar-pom for project:
      com.polk.vindecoder:vindecoder:pom:0.0.1-SNAPSHOT
      at
      org.apache.maven.project.DefaultMavenProjectBuilder.assembleLineage(DefaultMavenProjectBuilder.java:1161)
      at
      org.apache.maven.project.DefaultMavenProjectBuilder.buildInternal(DefaultMavenProjectBuilder.java:674)
      at
      org.apache.maven.project.DefaultMavenProjectBuilder.buildFromSourceFileInternal(DefaultMavenProjectBuilder.java:416)
      at
      org.apache.maven.project.DefaultMavenProjectBuilder.build(DefaultMavenProjectBuilder.java:192)
      at hudson.maven.MavenEmbedder.readProject(MavenEmbedder.java:269)
      at hudson.maven.MavenModuleSetBuild$PomParser.invoke(MavenModuleSetBuild.java:536)
      at hudson.maven.MavenModuleSetBuild$PomParser.invoke(MavenModuleSetBuild.java:494)
      at hudson.FilePath.act(FilePath.java:291)
      at
      hudson.maven.MavenModuleSetBuild$RunnerImpl.parsePoms(MavenModuleSetBuild.java:293)
      at hudson.maven.MavenModuleSetBuild$RunnerImpl.doRun(MavenModuleSetBuild.java:237)
      at hudson.model.AbstractBuild$AbstractRunner.run(AbstractBuild.java:192)
      at hudson.model.Run.run(Run.java:649)
      at hudson.maven.MavenModuleSetBuild.run(MavenModuleSetBuild.java:171)
      at hudson.model.ResourceController.execute(ResourceController.java:70)
      at hudson.model.Executor.run(Executor.java:64)
      Caused by: org.apache.maven.project.ProjectBuildingException: Error getting POM
      for 'com.polk.community:base-jar-pom' from the repository: Unsupported Protocol:
      'http': Cannot find wagon which supports the requested protocol: http
      com.polk.community:base-jar-pom:pom:0.0.1

      from the specified remote repositories:
      polk.releases (http://maven-proxy.../libs-releases@repo),
      polk.snapshots (http://maven-proxy.../libs-snapshots@repo),
      java.net (https://maven-repository.dev.java.net/nonav/repository/),
      snapshots (http://maven-proxy.../repo),
      central (http://maven-proxy.../repo)

      at
      org.apache.maven.project.DefaultMavenProjectBuilder.findModelFromRepository(DefaultMavenProjectBuilder.java:501)
      at
      org.apache.maven.project.DefaultMavenProjectBuilder.assembleLineage(DefaultMavenProjectBuilder.java:1157)
      ... 14 more
      Caused by: org.apache.maven.artifact.resolver.ArtifactResolutionException:
      Unsupported Protocol: 'http': Cannot find wagon which supports the requested
      protocol: http
      com.polk.community:base-jar-pom:pom:0.0.1

      from the specified remote repositories:
      polk.releases (http://maven-proxy.../libs-releases@repo),
      polk.snapshots (http://maven-proxy.../libs-snapshots@repo),
      java.net (https://maven-repository.dev.java.net/nonav/repository/),
      snapshots (http://maven-proxy.../repo),
      central (http://maven-proxy.../repo)

      at
      org.apache.maven.artifact.resolver.DefaultArtifactResolver.resolve(DefaultArtifactResolver.java:140)
      at
      org.apache.maven.artifact.resolver.DefaultArtifactResolver.resolve(DefaultArtifactResolver.java:63)
      at
      org.apache.maven.project.DefaultMavenProjectBuilder.findModelFromRepository(DefaultMavenProjectBuilder.java:467)
      ... 15 more
      Caused by: org.apache.maven.wagon.TransferFailedException: Unsupported Protocol:
      'http': Cannot find wagon which supports the requested protocol: http
      at
      org.apache.maven.artifact.manager.DefaultWagonManager.getRemoteFile(DefaultWagonManager.java:325)
      at
      org.apache.maven.artifact.manager.DefaultWagonManager.getArtifact(DefaultWagonManager.java:282)
      at
      org.apache.maven.artifact.manager.DefaultWagonManager.getArtifact(DefaultWagonManager.java:244)
      at
      org.apache.maven.artifact.resolver.DefaultArtifactResolver.resolve(DefaultArtifactResolver.java:124)
      ... 17 more
      Caused by: org.apache.maven.wagon.UnsupportedProtocolException: Cannot find
      wagon which supports the requested protocol: http
      at
      org.apache.maven.artifact.manager.DefaultWagonManager.getWagon(DefaultWagonManager.java:99)
      at
      org.apache.maven.artifact.manager.DefaultWagonManager.getRemoteFile(DefaultWagonManager.java:319)
      ... 20 more
      Caused by:
      org.codehaus.plexus.component.repository.exception.ComponentLookupException:
      Component descriptor cannot be found in the component repository:
      org.apache.maven.wagon.Wagonhttp.
      at
      org.codehaus.plexus.DefaultPlexusContainer.lookup(DefaultPlexusContainer.java:323)
      at
      org.codehaus.plexus.DefaultPlexusContainer.lookup(DefaultPlexusContainer.java:440)
      at
      org.apache.maven.artifact.manager.DefaultWagonManager.getWagon(DefaultWagonManager.java:94)
      ... 21 more
      finished: FAILURE

        Attachments

          Issue Links

            Activity

            kutsal kutsal added a comment -

            Oh forgot to add: We have artifactory 1.2.1 configured to cache everything
            locally on our CI server.

            kohsuke Kohsuke Kawaguchi added a comment -

            Fixed in 1.162.

            kohsuke Kohsuke Kawaguchi added a comment -
                • Issue 1023 has been marked as a duplicate of this issue. ***

              People

              Assignee:
              Unassigned Unassigned
              Reporter:
              kutsal kutsal
              Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: