Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-13999

The new discover permission breaks the tabbed view

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Incomplete
    • Component/s: core
    • Labels:
      None
    • Environment:
      Jenkins 1.466
    • Similar Issues:

      Description

      On my homepage I'm using various tabs to display data of my server
      If I give to the anonymous user the discover permission all tabs are disappearing for non-authenticated users.
      I attach all screenshots to show you the issue

        Attachments

          Issue Links

            Activity

            evernat evernat added a comment -

            @Arnaud
            Is it reproduced with a recent Jenkins version?

            joshuaayson Joshua Ayson added a comment -

            We have the same issue and are using Jenkins 1.536. We like having the 'discover' option off, because then users only see builds with permissions explicitly assigned to them. (works in folders as well, which is what we use)

            aheritier Arnaud Héritier added a comment -

            This problem disappeared (but I don't remember when)
            See https://ci.exoplatform.org/
            I'm using Jenkins 1.532.1 and the latest version of plugins for this version.
            The anonymous user has the discover right

            evernat evernat added a comment -

            thanks Arnaud

            @Joshua
            This issue description and reproducing depends on you now.
            Perhaps, you should close this one and create a new issue to better describe your problem.

            danielbeck Daniel Beck added a comment -

            Can anyone still reproduce this in recent Jenkins versions, or is this obsolete?

            joshua_ayson Joshua ayson added a comment -

            @Daniel - I stopped trying to use Jenkins this way and got over the fact that anonymous users can see all the builds and view the logs.

            danielbeck Daniel Beck added a comment -

            Resolving as 'Incomplete' after no positive response to comment asking for updated information in over three weeks.


              People

              Assignee:
              Unassigned Unassigned
              Reporter:
              aheritier Arnaud Héritier
              Votes:
              1 Vote for this issue
              Watchers:
              4 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: