Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-14326

SUBVERSION POLLING doesn't pick up the TRUNK (default value) [using ListSubversionTagsParameterDefinition] if the latest build used a specific TAG

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Minor
    • Resolution: Cannot Reproduce
    • Component/s: subversion-plugin
    • Labels:
      None
    • Environment:
      Jenkins ver. 1.473
    • Similar Issues:

      Description

      Job Configuration:
      </properties>
      </hudson.model.ParametersDefinitionProperty>
      </parameterDefinitions> <hudson.scm.listtagsparameter.ListSubversionTagsParameterDefinition>
      <name>SVN_PATH</name>
      <description>Select a Subversion entry</description>
      <tagsDir>http://172.22.2.1/repos/xxxx</tagsDir>
      <tagsFilter></tagsFilter>
      <reverseByDate>true</reverseByDate>
      <reverseByName>false</reverseByName>
      <defaultValue>trunk</defaultValue>
      <maxTags></maxTags>
      <uuid>a36be2b9-5c6d-427a-af70-cebbad5e6a87</uuid>
      </hudson.scm.listtagsparameter.ListSubversionTagsParameterDefinition>
      </parameterDefinitions>
      </hudson.model.ParametersDefinitionProperty>
      </properties>
      <triggers class="vector">
      <hudson.triggers.SCMTrigger>
      <spec>30 19 * * *</spec>
      </hudson.triggers.SCMTrigger>
      </triggers>

      Latest build was launched manually using a tag instead the trunk (default value):

      <hudson.scm.listtagsparameter.ListSubversionTagsParameterValue>
      <name>SVN_PATH</name>
      <tagsDir>http://172.22.2.1/repos/xxxx</tagsDir>
      <tag>tags/release-3.0-7121</tag>
      </hudson.scm.listtagsparameter.ListSubversionTagsParameterValue>

      Subversion Polling Log

      Started on 04-Jul-2012 19:31:13
      Received SCM poll call on ub-plat-bld-1 for HNBGW_nightly_seed on 04-Jul-2012 19:31:16
      http://172.22.2.1/repos/xxxx/tags/release-3.0-7121 is at revision 7,552
      Done. Took 8.8 sec
      No changes

      For some reason, the subversion polling instead to pick up the default tag, which is defined in the job configuration, it is using the unexpected tag, which was used in the latest build.

      Any clue?

        Attachments

          Issue Links

            Activity

            recena Manuel Recena Soto added a comment -

            Victor Martinez, Did you try with the latest version of Subversion Plugin?

            v2v Victor Martinez added a comment -

            Uhm... long time since I raised this ticket. so I'll close it as obsoleted since i don't have access to that environment and be able to reproduce it


              People

              Assignee:
              recena Manuel Recena Soto
              Reporter:
              v2v Victor Martinez
              Votes:
              2 Vote for this issue
              Watchers:
              4 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: