Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-193

Auto refresh mode annoying on "edit description" form

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: core
    • Labels:
      None
    • Environment:
      Platform: All, OS: All
    • Similar Issues:

      Description

      The fix for issue #130, auto refresh mode, leaves A.R. on even for console and
      config pages. For these pages the A.R. should be suppressed (without touching
      the cookie). In the case of the console, there is already an incremental display
      for running builds, and A.R. on an enormous log which already takes half a
      minute to render is no good. In the case of the config page, Firefox at least
      seems to retain customized form fields even after the refresh, but other
      browsers may not and this is certainly disconcerting.

        Attachments

          Issue Links

            Activity

            jglick Jesse Glick added a comment -

            Maybe instead of using HTTP refresh, those pages with refreshable data should
            use some AJAX to replace the relevant HTML section. If done properly, it would
            be unintrusive enough to turn on by default, I think. Ideally some Jelly/Stapler
            hackery would let you just write e.g.

            ...
            <l:refreshable id="build-status">
            ...as before...
            </l:refreshable>

            When rendered, the body would be displayed normally, but in a <div>; a JS timer
            would be added to the page, which would request from the server

            http://hudson/..../thisPage?refresh=build-status

            The server would respond with just that section, which would then be converted
            to DOM and displayed.

            kohsuke Kohsuke Kawaguchi added a comment -
                • Issue 228 has been marked as a duplicate of this issue. ***
            kohsuke Kohsuke Kawaguchi added a comment -

            Subject updated to reflect what's remaining to be done.

            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in hudson
            User: : kohsuke
            Path:
            trunk/hudson/main/core/src/main/resources/hudson/model/AbstractModelObject/editDescription.jelly
            trunk/hudson/main/core/src/main/resources/lib/hudson/editableDescription.jelly
            trunk/www/changelog.html
            http://fisheye4.cenqua.com/changelog/hudson/?cs=10605
            Log:
            [FIXED JENKINS-193] Fixed an interference between auto refresh and inline description editing. In 1.232.
            Gradually we should phase out auto refresh by AJAX, which is tracked as JENKINS-484

            jglick Jesse Glick added a comment -

            Seems this should have been marked FIXED long ago?


              People

              Assignee:
              kohsuke Kohsuke Kawaguchi
              Reporter:
              jglick Jesse Glick
              Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: