Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-20431

Can't select "Settings file" for maven build step in free-style project

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Labels:
      None
    • Environment:
      Server: Jenkins LTS 1.509.4 with Config File Provider Plugin 2.7.1 on Windows server
      Client: Firefox 24.0 on Windows 7
    • Similar Issues:

      Description

      On a free-style project where I have a maven build step (Invoke top-level Maven targets), the Settings file selecting doesn't work. Whatever I select, when I return to the config page "provided settings.xml" is selected with no Provided Settings chosen. So I can't switch to default settings.xml, not can I select one of the provided settings.xml.

      I'm fairly sure this did work with a pre-2.7 version of the plugin. I have been able to select a provided settings.xml in the past.

        Attachments

          Issue Links

            Activity

            domi Dominik Bartholdi added a comment -

            do you have any errors in the logs?
            I'm not able to reproduce this...

            ahammar Anders Hammar added a comment -

            No, nothing in the logs. Did you try the LTS version of Jenkins or the latest and greatest release?

            ahammar Anders Hammar added a comment -

            I can recreate this with a fresh installation of Jenkins LTS 1.509.4.

            ahammar Anders Hammar added a comment -

            OK, did test with Jenkins 1.531 (for some reason latest 1.540 bails right after start so I can't test) and with that version I can't reproduce. So it's something with the LTS version. Any ideas? Can it be fixed in the plugin?

            domi Dominik Bartholdi added a comment -

            fixed with core 1.526


              People

              Assignee:
              domi Dominik Bartholdi
              Reporter:
              ahammar Anders Hammar
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: